[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Re: Help--update killed everything



OK. I just noticed something strange. When I try to update the chroot area, if I leave it with the default repos enabled, I get no updates. If I add

deb http://us.archive.ubuntu.com/ubuntu intrepid-updates main restricted

to get backports, it wants to install lilo and mbr, but I'm pretty sure I don't want those in a thin-client image. Is there something weird going on? Do I really want lilo and mbr? Should I remove them manually after they're installed?

This is just silly...

Todd

On Wed, Dec 17, 2008 at 8:46 AM, Todd O'Bryan <toddobryan gmail com> wrote:
OK. I tried getting rid of the lts.conf file so that it would use all the defaults. Same problem.
I tried with the lts.conf file that worked with 8.04. Same problem.

I reverted to the old 8.04 ltsp image and, as long as I get rid of the lts.conf file that was working yesterday, it works. That is, students boot from an 8.04 image and then run from the server, which is running 8.10. Obviously, this is not an ideal solution--I can imagine there being incompatibilities between the libraries installed, but it's working for right now.

I've done ltsp-update-sshkeys, I've done ltsp-update-image. Anything else I can try?



On Wed, Dec 17, 2008 at 8:16 AM, Todd O'Bryan <toddobryan gmail com> wrote:
Scratch that. I had ssh'ed to the wrong server. Which could explain why none of the changes I made did anything. :-/


On Wed, Dec 17, 2008 at 8:04 AM, Todd O'Bryan <toddobryan gmail com> wrote:
Another piece of information. For some reason the update from 8.04 to 8.10 just deleted--completely--my lts.conf file in /var/lib/tftpboot/ltsp/i386. In fact, the tftpboot directory and everything below it got wiped out from /var/lib. I guess I'd call that a bug in the upgrade process.


On Wed, Dec 17, 2008 at 7:33 AM, Todd O'Bryan <toddobryan gmail com> wrote:
Sorry for the cross-post, but students are arriving in 15 mins and I'm desperate.

I updated my two Ubuntu 8.04 servers with LTSP to 8.10 last night. Once they finished, I copied over my old LTSP images to /opt/ltsp-8.04 and ran ltsp-build-client from scratch to create a new image.

Now, when I boot the clients, something very strange happens.

I use Ctrl+Alt+F1 to follow the boot progress in the terminal. After displaying the "Loading hardward drivers" (which takes a while) message, the background flashes green. It gets to the "Creating authfile...(something)" message and then the monitor goes black. Not only that, whatever signal the client is sending to the monitor is so offensive that at this point, not even the monitor menu button on the front works.

The clients are NTAVO 6020P's and the monitors are HP 1706's.

Any ideas what could be going on?

Todd





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]