[K12OSN] LTSP server with 3 NICs? SOME SUCCESS!

"Terrell Prudé Jr." microman at cmosnetworks.com
Wed Dec 24 18:22:47 UTC 2008

Answers in-line.


Joseph Bishay wrote:
> Hello,
> So I've been tearing out and rebuilding most of the I.T. in the
> building for the past few days.  My goal is to have it all up again by
> the end of this week.
> A lot of postings were about how it was a bad idea to be running
> K12LTSP fedora core 6 as the main machine, so I took this opportunity
> to backup and then wipe the LTSP server.  I've installed a clean
> K12LTSP CentOS EL version on it and tried to set it up from the start
> for 3 NIC functionality.

Good idea.  FC6 hasn't been supported now for a year.  You did the right 

> (I've also installed both IPCOP with squidguard and another centos
> webserver/mailing list so it's been a busy few days!)
> Back to the 3-NIC problem.  I noticed that somehow, something was
> crossed with all the cables going in and out of the switch, and I
> think at some point an Internet connection from the router was plugged
> into the LTSP switch.  Not sure if this was affecting the TFTP or not,
> I pulled out all the cables and just plugged in one client and the
> server into the switch.  I was able to get, when I plug the switch
> into the default LTSP NIC, to get a client to boot.  Well, technically
> it failed with some sort of failed to find the opt/i386 kernel or such
> and gave you 4 possible fixes.  Hunting through the email archive the
> solution was to modify /etc/exports to add two lines for
> /opt/ltsp/i386 and /var/opt/ltsp/swapfiles for the secondary network.
> I also went into lts.conf and added TWO server lines:  server =
> AND server =  Doing that got the client
> to boot so half the problem is solved!

Shoot us a copy of your /etc/exports file.  I forgot to ask for that 
before.  I might've even forgotten to tell you to modify that file.

Also, each subnet's lts.conf file needs only one "server = " entry.  
That would be the IP address applicable to that subnet.

Oh, one other thing:  when I did this, I had the following three 


which meant that each segment's DHCP scope entry pointed to a separate 
directory.  That is, pointed to /opt/ltsp/i386, 
pointed to /opt/ltsp/ppc, and pointed to /opt/ltsp/sparc.

Try this:

Make a copy of your entire /opt/ltsp/i386 directory and call it, say, 
"/opt/ltsp/i386-3".  Then, tweak your /etc/dhcp.conf file to point the scope to "/opt/ltsp/i386-3" instead of "/opt/ltsp/i386".  Of 
course, ensure that the lts.conf file in /opt/ltsp/i386-3 contains the 
appropriate entries for 192.168.3.x.  Again, you only need one "server = 
" entry per lts.conf file.

> Now, the question becomes, why when I plug the switch into the
> secondary LTSP NIC, do the clients hang at 'loading
>"?  I assume that tftp is working since
> they do boot when plugged into the other NIC.
That means that your basic functionality is indeed there.  We're almost 

> Just to clarify -- when I installed CentOS, I setup the networks as follows:
> eth0 - 192.168.2.XXX - LTSP network No. 1 - works fine!
> eth1 - Internet NIC
> eth2 - 192.168.3.XXX - LTSP network No. 2 - hangs!
> So close to a solution!

More information about the K12OSN mailing list