[K12OSN] Network unreachable.

Les Mikesell les at futuresource.com
Fri Feb 15 03:02:29 UTC 2008

Accessys at smart.net wrote:
> I didn't change anything since It was last working
> I can ping the router
> other than that I wish I knew what you just said????

SIOCADDRT means that when you tried to add a route, you didn't have 
access to the gateway.  That could mean the interface wasn't up, the 
address was wrong or the netmask was wrong.

I'd try:
ifdown eth0
ifup eth0
to make it go through the motions again.  If it is still the same try:
traceroute -n  some_internet_address
and see how far your packets go.

You can use "ifconfig" to see your configuration, "route" to see your 
routes (but they won't include the one that failed).  Something must be 
wrong with the combination of your address, netmask and gateway setting.

> I get so frustrated people either talk over my head or down to me
> why isn't there any place for someone who isn't a geek but does know a
> fair amount about these machines. 

There's a lot learn and most people only bother when they are forced to.

> I've complained about this for
> years, only two manuals are written.
> 1 for dummies books
> 2 uber geek.

The way to learn from something other than bad experience is to break 
things on purpose, then put them back together at a convenient time.

> is it any wonder people put up with 2 hours on hold to be told it is
> someeone else's fault.
> I'll get off my soapbox but it is probably the main reason Linux
> doesn't spread.

Everything breaks and this isn't more complicated than any other 
networking device.

   Les Mikesell
    lesmikesell at gmail.com

More information about the K12OSN mailing list