[K12OSN] Re: Some clients get Gray X Screen

Peter Scheie peter at scheie.homedns.org
Fri Jan 11 21:38:17 UTC 2008

I ran into the same head scratcher a while back: no gdm.conf, a custom.conf 
file, and yet a system that *does* work.  As I recall, custom.conf is the file 
you want to modify.  I think it might be a Red Hat thing, and/or a philosophy 
that "gdm.conf isn't usually modified but since it is sometimes, we'll call it 
custom.conf instead."  Mostly I recall thinking that the decision made things 
more confusing.  One of the great things one can say about Unix is that what one 
learned 20 years ago is still relevant; unfortunately, that's rarely the case 
with the GUI's on Linux. </rant>


Amy Contreras wrote:
> On 10/01/2008, Amy Contreras <acontreras at walkerville.k12.mi.us> wrote:
>> Ever since I've changed the XSERVER to VESA in the lts.conf file I've 
>> been able to get most of my Dell GX100 clients to work.  Although I 
>> still have a few that get the gray screen with an X cursor.  I can't 
>> quite figure it out
> AFAIK If the xserver was failing you would not get  gray screen with an
> X. This could be some other problem. See chapter on grayX at
> http://ltsp.mirrors.tds.net/pub/ltsp/docs/ltsp-4.1-en.html#AEN965
> Is this happening randomly? If yes then maybe you need to increase
> number of sessions in the gdm.conf file. Or check if allocating lesser
> memory in BIOS for video will work. And try i810 driver instead of vesa
> for the GX100's...
> --
> Regards,
> Sudev Barar
> Read http://blog.sudev.in for topics ranging from here to there.
> Sudev,
> Yes you're correct, the xserver was a separate issue and adding vesa
> took care of it. I probably didn't need to mention that.  The clients
> that get the grayX screen have always had this problem since initially
> trying to get them to boot to the server.  It's not random. I tried what
> you mentioned and neither of those suggestions worked for me. When I
> replaced vesa with i810 it went back to giving me the xserver failed
> error.
> Also, when trying to locate the gdm.conf file it's not there. I thought
> it should be in the /etc/X11/gdm folder.  However, I found the
> /etc/gdm/custom.conf file with a GDM configuration.  Should I recreate
> the gdm.conf file using custom.conf? Although gdm appears to be running
> because I can login as I did before, only some clients still get the
> grayX screen.  Sorry if this sounds silly as I'm a bit confused why I
> don't have gdm.conf. I'm still a newb:)
> Thanks again,
> Amy Contreras
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>

More information about the K12OSN mailing list