[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] upgrade openoffice



hi.........see

www.imanlinuxer.blogspot.com

2007/11/29 James P. Kinney III <jkinney localnetsolutions com >:
Mel,

I'm assuming you are trying to install a _real_ Sun java in order to
make OpenOffice work better.

If so, try using rpm -ivh instead of -Uvh. There are a blasted number of
things that are clearly dependencies and upgrading the java from the
RedHat blessed version (of moderate junk that really doesn't work right
yet) to the real Sun java will try and replace the core and cause the
errors.

Note: there is a c++-compat lib (I think) that you will need to install
Sun java from an rpm.

On Wed, 2007-11-28 at 13:36 -0800, Mel Wade wrote:
> I get the following error:
>
> [root BoysDorm java]# rpm -Uvh *.rpm
> error: Failed dependencies:
>         java-gcj-compat >= 1.0.31 is needed by (installed)
> tomcat5-servlet-2.4-api-5.5.23-0jpp.1.0.3.el5.x86_64
>         java-gcj-compat is needed by (installed)
> xalan-j2-2.7.0-6jpp.1.x86_64
>         java-gcj-compat >= 1.0.31 is needed by (installed)
> xml-commons-apis-1.3.02-0.b2.7jpp.10.x86_64
>         java-gcj-compat is needed by (installed)
> xml-commons-resolver-1.1-1jpp.12.x86_64
>         java-gcj-compat >= 1.0.31 is needed by (installed)
> xerces-j2-2.7.1-7jpp.2.x86_64
>         java-gcj-compat is needed by (installed)
> hsqldb-1.8.0.4-3jpp.4.x86_64
>         java-gcj-compat >= 1.0.31 is needed by (installed)
> tomcat5-jsp-2.0-api-5.5.23-0jpp.1.0.3.el5.x86_64
>         java-gcj-compat is needed by (installed)
> bsf-2.3.0-11jpp.1.x86_64
>         java-gcj-compat is needed by (installed)
> bsh-1.3.0-9jpp.1.x86_64
>         java-gcj-compat >= 1.0.64 is needed by (installed)
> gjdoc-0.7.7-12.el5.x86_64
>         java-gcj-compat is needed by (installed)
> antlr-2.7.6-4jpp.2.x86_64
>         java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
> (installed) java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp.112.x86_64
>         java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
> (installed) java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.112.x86_64
>         java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
> (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112.x86_64
>         java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
> (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112.i386
>         /usr/bin/rebuild-gcj-db is needed by (installed)
> eclipse-ecj-3.2.1-18.el5.centos.1.x86_64
> [root BoysDorm java]#
>
> --
> Mel Wade
> "The real problem is not whether machines think but whether men do." -
> BF Skinner
> http://www.melwade.com
>
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see < http://www.k12os.org>
--
James P. Kinney III
CEO & Director of Engineering
Local Net Solutions,LLC
770-493-8244
http://www.localnetsolutions.com

GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
<jkinney localnetsolutions com>
Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]