[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] CentOS + USB devices



On Thu, May 22, 2008 at 2:17 PM, Marc Fromm <Marc Fromm wwu edu> wrote:
> I'm setting up a new k12ltsp server. Our current server (not setup by
> me) has USB printer directly attached to a client and it is setup in
> CUPS using Device URI socket://finaid76:9100 since that client is always
> logged on with user account finaid76.
>
> The lts.conf file has an entry
> [finaid76]
>        PRINTER_0_DEVICE        =/dev/usb/lp0
>        PRINTER_0_TYPE          = U
>
> Since there are no clear instructions with printers I am duplicating
> configurations that currently work.

Ah ... a beginning point for printers is
http://www.ltsp.org/twiki/bin/view/Ltsp/Printers

The 'trick' is that you need to add a DHCP reservation for each thin
client that will have a printer attached to ensure that the thin
client always has the same IP address and hostname.

>
> For USB thumb drives, what is the Fuse group?

In looking at the latest docs for ltsp on ltsp.org's wiki, it seems
that this might not be needed.  but for my systems, I had to create a
user group called fuse and add all my users to it so that the drives
were automounted correctly. Since it worked, I've kept adding users to
this group.

Fuse should be part of the main kernel now, but if not CentOS should
be similar to http://www.ltsp.org/twiki/bin/view/Ltsp/LtspFS#Installing_FUSE_on_Fedora_Core

Sincerely,
Dave Hopkins

>
> -----Original Message-----
> From: k12osn-bounces redhat com [mailto:k12osn-bounces redhat com] On
> Behalf Of David Hopkins
> Sent: Thursday, May 22, 2008 11:07 AM
> To: Support list for open source software in schools.
> Subject: Re: [K12OSN] CentOS + USB devices
>
>> Are the usb ports disabled on the client machines in k12ltsp CentOS?
>> I have plugged in a usb thumb drive and a printer into a client and
>> neither are detected. I plugged the same usb thumb drive into the
> server
>> box and it was detected.
>>
>
> They work for me, but users need to be in the Fuse group.
>
>> I added the printer using the CUPS web interface localhots:631.
>> I used Device URI: socket://finaid70:9100
>
> Is this correct? Isn't it socket://IP_address_thin_client:9100 or
> socket://hostname_of_thin_client:9100 (which are typically 192.168.x.y
> and ws###.ltsp for the base install).  We have 80+ printers connected
> to thin clients and they work fine but we are using the parallel port
> for the printers, not the usb port.
>
> Sincerely,
> Dave Hopkins
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]