[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] no audio in i810 soundcard



Hi Alberto,

I have some note in the body of your message below:

On Wed, 2008-05-28 at 19:26 -0300, Alberto Castillo wrote:
> Hi everybody!
> I write from Argentina! so sorry for my bad english, I try to explain
> to clear as possible:
> 
> I have many thin clients of same type: "Compaq Deskpro Ex
> Microtower" (color white) - Celeron 566 - 64MB RAM - Motherboard Intel
> (I supose)
> 
> The trouble is that I do not have sound in the terminals.
> 
> The system: k12EL5.0 (the last).
> 
> The hardware of thin client (from the original service manual):
>      
> Chipset Component         Function
> 810e    82810e-DC100 GMCH AGP 2X interface
>                           Direct AGP graphics controller
>                           SDRAM controller supporting up to 2 PC100
> DIMMs
>                           66-/100-/133-MHz FSB
>             82801AB ICH       PCI bus I/F
>                           LPC bus I/F
>                           SMBus I/F
>                           IDE I/F with UATA/66 support
>                           AC '97 controller
>                           RTC/CMOS
>                           IRQ controller
>                           Power management logic
>                           USB I/F
>                           8259 or I/O APIC interrupt processing
>            82802 FWH         Loaded with AMI BIOS
> 815     82815 GMCH        AGP 4X interface
>                           Direct AGP graphics controller
>                           SDRAM controller supporting up to 2 PC133
> DIMMs
>                           66-/100-/133-MHz FSB
>         82801AB ICH       Same as for 810e Chipset
>         82802 FWH         Loaded with Compaq BIOS
> 
> 
> 
> I check if in the screen of terminal when boots, detect the sound card
> (onboard) and yes:
> i810: Intel ICH 82801AA found at IOx0d800 and 0xdc00, MEM 0x0000 and
> 0x0000 IRQ 11.
> 
> I check if listen the port 16001 and yes:
> - accepting connections on port 16001
> 
> I check if the "-public" option is present in sound.rc and yes:
> export ESD_SPAWN_OPTIONS="-public"
>                /bin/esd -nobeeps -tcp -port 16001 -as 1 -public &

Here's a trick: remove the "-nobeeps" and reboot the clients. Now when
the start up ESD you will hear a series of 3 (or 4) beeps rising in
pitch. If some clients do this and others do not, the detection of the
sound chip is a problem.
> 
> My lts.conf file in part sound:
> # enable sound by default
>         SOUND              = Y
>         # choose either esd or nasd to be the default (esd only on
> x86_64)
>         SOUND_DAEMON       = "esd"
> #        SOUND_DAEMON     = "nasd"
>         #RCFILE_0x = sound.rc
> 
>         # default sound volume
>         VOLUME             = 75

I have found that setting this to about 90 works better. 75 is to low to
hear anything.
> 
>         ### For ISA sound cards, you have to specify the module to
> use:
>        # SMODULE_01       = "sb io=0x220 irq=5 dma=1"
> 
> In the grafic user in gnome, when I try to open the mixer I have a
> error tell me some that "gstreamer no encounter .. no device..", 
OK. Remember how all this stuff works. Any application you see on the
client screen is running on the server hardware. So volume control won't
work. 

> when I play a audio with xmms, hi tell me that the sund is blocked by
> other applicattion, when I try to autodetect the sound card from the
> client, this modifies the values of volume of my server, and I can
> see, I think, the soundcard of my server, that is a i810 too!
> In KDE just I have entered, tell me that the sound is no initialize
> because I have no premissions...

I have had to make sure the /tmp/.esd/socket file existed on the server
for most sound stuff to work at all. In fact I had to make a cron job to
test and recreate it every hour if it went away for any reason. 
> 
> Please somebody can help me?
> Thank you a lot!
> Cheers from Argentina, sorry for mu bad english!

Your English was plenty good enough!
> 
> -- 
> This message has been scanned for viruses and 
> dangerous content by MailScanner, and is 
> believed to be clean. 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
-- 
James P. Kinney III          
CEO & Director of Engineering 
Local Net Solutions,LLC                           
http://www.localnetsolutions.com

GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
<jkinney localnetsolutions com>
Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]