[K12OSN] ltsp-build-client - command not found

Nils Breunese nils at breun.nl
Sun Nov 2 21:53:37 UTC 2008

Brian Fristensky wrote:

>> On my F9 system, ltsp-build-client is in /usr/sbin/, and rpm shows  
>> that it
>> was installed via the ltsp-server package.  Since you have to be  
>> root to do
>> all these steps, did you, by chance, use 'su' to become root  
>> instead of 'su
>> -' ? The former doesn't set root's environment, including the  
>> $PATH, meaning
>> it won't find all the various tools in /sbin, /usr/sbin, etc.
>> Peter
> Yes, that was the problem. When I ran it as /usr/sbin/ltsp-build- 
> client
> the command worked, correctly installing the files in /opt/ltsp.
> The instructions didn't specifically say to run the command
> as sudo, and I always find it convenient to have a terminal window
> open as root when I am doing sysadmin stuff. It is actually a bit
> surprising to me that su would not set root's $PATH,
> but I there are probably good reasons for that.

Well, su is short for substitute user. If you want to also change the  
environment, you have to add the dash (or -l or --login). See 'man su'  
for more info. You could alias 'su' to 'su -' if you like by adding  
the following to your .bashrc:

alias su='su -'

Nils Breunese.

More information about the K12OSN mailing list