[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] smbldap adjusting permissions from Windows



This is not resolved if we don't know why permissions changes weren't working on folders.

When viewing the properties pages of a share, from a Windows XP SMB client, if you switch to the "Security" tab, you are looking the permissions for the NTFS folder that is shared.  You are not looking at the share ACL, but the folder ACL.  To see share ACL from XP, try pointing Computer Management at your Samba server.  According to my look, my home-folder-share has an ACL of Everyone:FullControl.  That's not likely to cause any problem.  But every entity on every folder ACL has "special" permissions.  This problem needs exploration.

I have a feeling that the solution is somewhere in unix-side facls.  Like, if the filesystem is loaded "with ACL support", which I forget how to do, the changes to permissions might work correctly.

----- Original Message -----
From: "Rob Owens" <rob owens biochemfluidics com>
To: "Support list for open source software in schools." <k12osn redhat com>
Sent: Monday, November 17, 2008 6:42:20 AM GMT -07:00 US/Canada Mountain
Subject: Re: [K12OSN] smbldap adjusting permissions from Windows - SOLVED!


Almquist Burke wrote:
> 
> On Nov 14, 2008, at 6:20 AM, Rob Owens wrote:
> 
>> I was right-clicking on a folder within the share.  Are you saying that
>> attempts to change permissions on the whole share and not just that
>> folder?  If so, that would explain my problem (because my user wouldn't
>> have permission to change the whole share).  But it doesn't seem
>> intuitive.
> 
>> -Rob
> 
> 
> I don't have a windows box sitting here to test with at home so I'm not
> sure if that is the case. I just remember that the last time I gave
> myself headaches setting up a PDC using samba, that you had
> permissions/users that were set by samba AND users/permissions that
> pertained to the files/folders on the filesystem themselves. They have
> to work in tandem and getting the setup correct is tricky sometimes. The
> [Printers] and [Homes] sections have pretty bullet proof defaults for
> what they do, but setting up custom shares means you have to get your
> permissions and users/groups just right for both the filesystem and
> samba. Are you using the stick bit? groups? What do you want the share
> to do? If we know exactly what access you want to give, we might be able
> to help better. ... or it might just be buggy, or that first permissions
> screen really DOES apply to the shares and not the files/folders.

I'm really just trying to provide an open share that anybody can create
a file/folder in, while enabling users to change permissions on the
files/folders that they create.  It seems to be working now, but it
seemed odd to me that I couldn't use the first permissions screen to do
it (well, it worked for files, but not folders).

Thanks for your help.

-Rob
********************************************************

The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential and/or privileged
material. If you are not the addressee, any disclosure, reproduction,
copying, distribution, or other dissemination or use of this transmission in
error please notify the sender immediately and then delete this e-mail.
E-mail transmission cannot be guaranteed to be secure or error free as
information could be intercepted, corrupted lost, destroyed, arrive late or
incomplete, or contain viruses.
The sender therefore does not accept liability for any errors or omissions
in the contents of this message which arise as a result of e-mail
transmission. If verification is required please request a hard copy
version.

********************************************************


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]