[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] HELP!!



First thing is to get the NFS service back up and running. Without it,
if you are using NFS mounted /home, nothing will work right.

nfsstat will show data about the nfs server and client connections.

Open 2 console screens (<alt>-F1 and <alt>-F2) not X screens on the NFS
server. On screen 1 run tail -f /var/log/messages and on 2 run service
nfs stop; service nfs start
Now look at screen 1 for what is the problem. If stumped, grab the last
30-40 lines of /var/log/messages after this and post them here.

It may be that network settings are suddenly wrong and there is no NIC
on the same IP address as the nfs server (plugged wrong cable into
upstream dhcp server - it happens :-)

Last resort: shutdown -r now on the nfs server. Let it fully reboot and
watch the stat up screen for errors. Then restart the other servers. 

BTW: It's a good idea to do "destructive testing" and verify that a
simple reboot will restore functionality to a fouled up server. Have it
running and literally pull the plug. If it doesn't reboot without
"futzing" fix the reboot process so it does. fsck is the only
outstanding issue that can't (easily) be worked around.

On Tue, 2008-10-07 at 15:09 -0400, Randall Swift wrote:
> I have an authentication server running centOS and was setup using the
> smbldap script. For some reason students when they tried to access their
> home directory were getting "access denied" errors. I restarted ldap
> service and smb service but when I restart nfs it will not start. The
> system seems to hang and I have to force quit out of it. I also cannot
> even browse the filesystem with the gui the sytem hangs. I think the
> permissions are screwed up. If so, how do I redo those in bulk (i have
> over 650 users). I am desperate as we are down till I get this fixed.
> Thanks for the help.
> 
> Randy Swift
> Network Administrator
> Leavitt Area High School
> Turner, Maine 04282
> (207)225-3533
> swift msad52 org
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
> 
-- 
James P. Kinney III          
CEO & Director of Engineering 
Local Net Solutions,LLC                           
http://www.localnetsolutions.com

GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
<jkinney localnetsolutions com>
Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]