[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Sound : my nemesis



> Pulse is a replacement for esound so you can't have both installed at
> the same time (thus the conflict). Remember that the newer flash plugin
> only uses pulse.
>
Yep, and this flash issue is part of the reason for trying to get
pulse working.  I have uninstalled the conflicting esound rpms on the
server, but have the ltsp rpm installed so that the client should be
using esd.  There was a post earlier about how this can be done.  I'd
prefer to have pulseaudio at the client as well, but haven't sorted
out how to actually install the necessary libraries/et.al. in the
/opt/ltsp/i386 directories. Can't just chroot and run yum install ...

> It still needs the ports open on the server (and client) to allow the
> networked sound to be distributed. Also, KDE sound must be tweaked to
> make it work using the control panel. Once that works, it will need to
> be distributed to the users.
>

I don't have the firewall or selinux turned on at all on the servers.
All systems are behind multiple firewalls to start with so any attack
would have to originate on the school's internal network.  We use
Gnome, not KDE. I've tried to get users to switch but they are more
comfortable using Gnome.

> What happens if a thin client is booted from a Knoppix disk? Does sound
> work then?

The thin clients don't have cdrom drives, and I haven't tried a USB
boot disk. However, the exact same thin clients work without issues
when booted from the 32bit servers which are supposedly configured
exactly the same as the 64bit servers.

I had to leave the school at 3 yesterday, and I'm not at the school
today. I'll be back at the school tomorrow morning, and then again on
Friday.  I have a couple of clients set up so I can boot one from a
32bit server and the other from a 64bit server, side-by-side so I can
go line by line through output from lsmod, etc at the clients to make
sure that they are getting the same modules loads.  Since I can telnet
to the ones that work, and can't to the ones that don't, I must have
missed something though if /opt/ltsp is identical, not sure why they
would boot differently. Perhaps I should try rsync'ing the working
/opt/ltsp to the non-working one?  Can't do this during the day though
since these are production systems. I have good backups so restoring
the /opt/ltsp isn't a problem.

Sincerely,
Dave Hopkins


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]