[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] OT: Backuppc config issue



On Mon, Sep 1, 2008 at 5:46 PM, Nils Breunese <nils breun nl> wrote:
> David Hopkins wrote:
>
>> I installed Backuppc and am trying to simply verify that it will work
>> by running a backup against the backup server itself.  I created ssh
>> keys (for both root and the backuppc account) and can ssh into the
>> server without issues or prompts (e.g. ssh ncsfs2)
>>
>> Apache is running as backuppc (per the backuppc website since the only
>> use for apache on this system is to run the Backuppc cgi access).
>>
>> When I request a backup, I get the following (and this is slightly
>> different than the default which includes the --sender --server flags
>> but with those flags the command will not even run at all)
>>
>> Error message in Xfer.log
>>
>> full backup started for directory /home
>> Running: /usr/bin/ssh -q -x -l root ncsfs2 /usr/bin/rsync
>> --numeric-ids --perms --owner --group -D --links --hard-links --times
>> --block-size=2048 --recursive --checksum-seed=32761 --ignore-times .
>> /home/
>> Xfer PIDs are now 30065
>> Read EOF: Connection reset by peer
>> Tried again: got 0 bytes
>> Done: 0 files, 0 bytes
>> Got fatal error during xfer (Unable to read 4 bytes)
>> Backup aborted (Unable to read 4 bytes)
>>
>> I have added backuppc ALL=NOPASSWD:/usr/bin/rsync via visudo.
>>
>> I can run the command from a shell as root but the effect is to back
>> up root's home ('.' in the above) to /home/ which is not what is
>> desired at all.  I guess I must be very close to getting it working
>> but what is missing now has me baffled.
>
> Sounds like a question for the backuppc-users mailinglist. I happen to be on
> there and this is a fairly frequently asked question. First of all, try
> running that command as the backuppc user instead of root, since that's what
> BackupPC does. You need to OK the SSH fingerprint the first time you login
> via SSH and BackupPC can't do that for you. Make sure you login once
> yourself and OK the fingerprint. Afterwards BackupPC should be able to login
> automatically. If not you could have another problem, but I suggest taking
> this issue to the backuppc-users mailinglist (after checking the archives
> first of course).
>

Nils,

Thanks ... I only posted here because I know some of the backuppc
users/mailing list also are active here, especially Les.  As for the
things to test, I did the ssh test and when I run the command
presented as backuppc it errors out with insufficient permission to
write to /home which is strange since that is not what I want but it
is what the command is saying to do.  I have also searched the
backuppc mailing list, and googled till I am blue trying to figure it
out.  Posting here really was a last resort.  Guess I'll go join the
backuppc mailing list now and post the query there.

Sincerely,
Dave Hopkins


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]