[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Installing Anjuta on CentOS5



jones yeates wrote:

I changed my OS from Fedora to CentOS5 recently. I can't seem to install Anjuta. Below are the things that I've tried.

1.  yum install anjuta
--  It is not in the repositories

That's correct. RPMForge has it listed on http://dag.wieers.com/rpm/packages/anjuta/ , but I only see old versions and no packages for EL5 (although you could try and rebuild the src.rpm).

3. I found a 2.4.2 version of the source and tried to compile it. I got to ./configure and it would crash. Claiming that the VTE package could not be found. I got a VTE source file and was able to compile it without any problems. However it was supposed to be version 0.16.2 and when I did a yum info vte I get version 0.14.0. Anyhow, yum says vte has been installled.

When installing packages that are needed to build software, you need the -devel version. Did you install vte-devel? If the Anjuta source you have really requires vte 0.16.2 and you have 0.14.0 then I don't think that's going to work. You'll then need to also build vte 0.16.2 from source.

4. I found an .rpm version of Anjuta for distributions other than Fedora 3 and it stops at the public key thing. I don't have the public key so it stops.

Get the key and import it. Or if you trust the package without getting the key, you can tell your package manager to skip the key check: yum --nogpgcheck localinstall <downloaded-package>

Any suggestions?

You could try and find an IDE that is packaged for CentOS?

Nils Breunese.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]