[K12OSN] bootup slow -- nfs server not responding

Peter Scheie peter at scheie.homedns.org
Wed Sep 10 20:31:24 UTC 2008

Rob Owens wrote:
> george kocke wrote:
>> Rob Owens wrote:
>>> The reason I upgraded the RAM is because I've been getting slow boot
>>> times on the thin clients, with the message "nfs server not responding"
>>> showing up at least 10 times during the boot process.  The clients
>>> eventually boot successfully.  The upgrade didn't seem to help, but hey,
>>> it was cheap and easy to try.
>> Sorry if anyone else has responded with this, but the URL below helped
>> me when I ran into this problem:
>> http://wiki.ltsp.org/twiki/bin/view/Ltsp/NFS#NFS_Server_not_responding
> This seems to have solved my problem.  I only tested it on PXE so far,
> but the problem has completely disappeared when PXE booting.
> For the archives:
> My "append" line in pxelinux.cfg/default was slightly different than the
> one shown on the wiki.  I simply added:
> 	MOPTS=nolock,ro,wsize=2048,rsize=2048
> to the end of my existing "append" line.
I've had to use this same setting with some clients with 100Mb NICs when they 
are plugged into a gigabit port on the swithc (say, an 8-port switch with all 
gbit ports), even though they boot just fine when plugged into a 100Mb port (and 
server is plugged into the gbit port).


More information about the K12OSN mailing list