[K12OSN] Re: LTSP-5 on RHEL-5 questions

Warren Togami wtogami at redhat.com
Fri Sep 12 04:09:00 UTC 2008

> Hi Warren,
> I hope you don't mind a few questions on LTSP-5.  I work at REDACTED 
> REDACTED REDACTED ORG and have been tasked with investigating 
> using LSTP-5 clients on a network for scientists and 
> engineers who have some applications that require 3-D visualization.  We 
> can deploy thick clients, but thin is easier to manage.  At any rate, 
> clients are required to be diskless.  Also, we are limited to using Red 
> Hat Enterprise Linux version 5.

You do understand that due to limitations of RHEL5 combined with
extremely limited time resources, the client operating systems you are
booting by following those instructions is Fedora 9 right?

> That said, I followed the instructions that you outline for LTSP 5 on 
> RHEL 5.  It works. I can get clients to boot and can get an LDM session 
> on the server.  It's been fun learning and experimenting.  I have some 
> questions.  I realize you must get a lot of these types of e-mails.  
> Again, I hope you don't mind my imposition.

Please understand that any work I do on RHEL5 is entirely on my spare
time.  I am really burning myself out trying to achieve goals for Fedora
10 and eventually RHEL6 official support for all this.  Very behind
schedule on the software deliverables, and especially documentation for
all this.

The version of ltsp built in my repository there and the F9 chroot
tarball is 10 upstream versions ago.  I began fixing bugs to make it
possible to build the latest versions on RHEL5 again.  I will try to
test new builds of this to bring it up to a modern version this weekend.

> 1) My LDM session comes up fine.  However, if I switch to another 
> virtual console (ctrl-alt-f5) for example to get a local shell and then 
> switch back to the console running the LDM session, the entire LDM 
> display shifts to off center by about half the width on the monitor.  
> Have you or anybody else seen this behavior?  Can you suggest a fix or 
> way to troubleshoot it?

Sounds like an X video driver bug.  This is all nv video?  I have
personally not used nvidia hardware for ~7 years now because they have
been the least convenient for Linux driver support, so I do not have any
recommendations of a fix.  You may want to report a bug against
xorg-x11-drv-nv for Fedora 9.

> 2) We will be deploying some fairly high end client hardware - at least 
> a gigabyte of memory per client and an nvidia GEforce 8000 class video 
> card.  Is there a way to configure LTSP clients to do more of the video 
> processing locally on these more capable video cards to speed up the 
> graphics?  For example, I run "glxgears" on a server, displaying to the 
> console of a diskfull client.  When I display it on an LTSP client, the 
> performance is much slower than the diskfull client.  Note, that I am 
> using the nv driver and glx libraries that came in your LTSP 5 root tar 
> package.

Right.  nv has no 3D acceleration, so it would be significantly slower
than real hardware acceleration.

Please keep in mind that NVIDIA drivers are completely unsupported by
Red Hat and the Fedora Project.  They are closed source so we cannot
possibly support it.  That being said the following advice might be helpful.

Also know that 3D over the network, while possible, is much slower than
the application and X display on the same physical machine.

>   2a - If I were to download the driver install package from nvidia and 
> install that, would my performance improve?
>   2b - I actually tried to install the drivers from the nvidia install 
> package.  It was a daunting task.  I was not successful, since the 
> kernel and LTSP root for RHEL 5 are different from the RHEL 5 server's 
> kernel and root filesystem.  I must have gotten the wrong location for 
> the nvidia glx library, because it broke glx.  Basically, I tried 
> running the nvidia install script as:
> sh ./NVIDIA-Linux-x86-173.14.12-pkg1.run
> --x-module-path=/opt/ltsp/i386/usr/lib/xorg/
> --x-library-path=/opt/ltsp/i386/usr/lib \
>  --x-prefix=/opt/ltsp/i386/usr/X11R6
> --utility-prefix=/opt/ltsp/i386/usr
> --kernel-source-path=/usr/src/kernels/ \
>  --kernel-install-path=/opt/ltsp/i386/lib/modules/
> --kernel-name= \
>  --no-runlevel-check --no-x-check

You are essentially booting Fedora 9 read-only roots on your thin
clients.  Your best bet is to use Livna to get NVIDIA rpms of the kernel
module and X drivers for a matching Fedora 9 kernel in your chroot.
Luckily it appears that their repo has i586 kernel module builds to
match the i586 kernel in the LTSP chroot.

Another issue that you will run into: The LTSP clients with read-only
root have no xorg.conf by default.  Normally X autodetects what video
card you have and uses a matching driver for your card.  But since
nvidia is a non-standard driver, it cannot be autodetected and
autoconfigured in this manner.

There is a workaround for this.  lts.conf has an option X_CONF where you
can specify the path of an alternate xorg.conf file.  You could create
something like /opt/ltsp/i386/etc/X11/xorg-nvidia.conf and have lts.conf
point at it.  That config file could have only the minimum necessary
sections to specify the nvidia driver, and it can attempt to autodetect
everything else like monitor resolution and input devices.

> Would I also need to add the NVIDIA kernel module to the initrd image?  
> Does "ltsp-update-kernels" do that, or does it simply copy the kernel 
> and initrd from /opt/ltsp/i386/boot?

ltsp-update-kernels will only copy the initrd images from /boot of the
client chroot into the tftpboot directory that is used during PXE booting.

AFAIK, nvidia kernel modules are not needed in the initrd.

Warren Togami
wtogami at redhat.com

More information about the K12OSN mailing list