[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] K12LTSP 5 EL: no Web access for non-terminal clients



Sorry Rob. The first reply only went to you not the list. Here is another try.

Ok, I checked /proc/sys/net/ipv4/ip_forward and it has a 1 in it. I looked at /etc/dhcpd.conf and all it has in it is:

#
# DHCP Server Configuration file.
#   see /usr/share/doc/dhcp*/dhcpd.conf.sample 
#

When I added the option routers x.x.x.x line in it and I did a service dhcpd restart, dhcpd failed to start. I reverted to the original dhcpd.conf file and tried again and still got a failure on start. I see that there is a dhcpd-k12ltsp.conf file. Is this the one that is actually used? It seems like I remember older versions of K12LTSP had a line in dhcpd.conf pointing to dhcpd-k12ltsp.conf. Is this what is supposed to happen?

Maybe my looking around with Webmin messed things up. I didn't see any error messages in /var/log/messages so I'm at a loss here. I'd rather not have to start over again.


David D. Nelson
nelsda yahoo com

http://www.evalbum.com/1328


--- On Fri, 9/19/08, Rob Owens <rob owens biochemfluidics com> wrote:

> From: Rob Owens <rob owens biochemfluidics com>
> Subject: Re: [K12OSN] K12LTSP 5 EL: no Web access for non-terminal clients
> To: nelsda yahoo com, "Support list for open source software in schools." <k12osn redhat com>
> Date: Friday, September 19, 2008, 5:00 AM
> Your DHCP server (which I assume is your K12LTSP server)
> needs to tell
> clients where the gateway is.  dhcpd.conf should have a
> line like:
> 
> option routers 10.112.0.123;  (obviously, don't use my
> example address)
> 
> Your thin clients have web access because they're
> nat'ing to the K12LTSP
> server, and the K12LTSP server apparently knows where its
> gateway
> (router) is.  The other clients, though, need to be told
> where their
> gateway (router) is.
> 
> -Rob
> 
> David D. Nelson wrote:
> > My server died and I had to do a new install so I did
> a standard install K12LTSP 5 EL. After applying updates
> terminals would boot and work fine but I can't seem to
> get any access from other workstations on the network. I
> have eth0 on the local net and eth1 to the internet. I tried
> the following:
> > 
> >     chkconfig nat on
> >     service nat restart
> > 
> >     chkconfig iptables-k12ltsp on
> >     service iptables-k12ltsp restart
> > 
> >     chkconfig transparent-proxying on
> >     service transparent-proxying restart
> > 
> > but I still don't have internet access from the
> workstations. I'm able to ping by domain name so I
> assume that DNS is set up correctly but I get an invalid
> request error from squid or a time out if squid isn't
> running.
> > 
> > Any ideas?
> > 
> > TIA,
> > 
> > David D. Nelson
> > nelsda yahoo com
> > 
> > http://www.evalbum.com/1328
> > 
> > 
> >       
> > 
> > _______________________________________________
> > K12OSN mailing list
> > K12OSN redhat com
> > https://www.redhat.com/mailman/listinfo/k12osn
> > For more info see <http://www.k12os.org>
> ********************************************************
> 
> The information transmitted is intended only for the person
> or entity to
> which it is addressed and may contain confidential and/or
> privileged
> material. If you are not the addressee, any disclosure,
> reproduction,
> copying, distribution, or other dissemination or use of
> this transmission in
> error please notify the sender immediately and then delete
> this e-mail.
> E-mail transmission cannot be guaranteed to be secure or
> error free as
> information could be intercepted, corrupted lost,
> destroyed, arrive late or
> incomplete, or contain viruses.
> The sender therefore does not accept liability for any
> errors or omissions
> in the contents of this message which arise as a result of
> e-mail
> transmission. If verification is required please request a
> hard copy
> version.
> 
> ********************************************************


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]