[K12OSN] Open Office problem!

David Hopkins dahopkins429 at gmail.com
Sat Jan 10 15:51:11 UTC 2009

> However, two issues.  I was confused by your steps with respect to the
> desktop integration.  After using the ./setup command to get the
> program installed, my currently existing open office icons no longer
> work.  Clicking them gives the error:
> "Could not launch application  Failed to execute child process
> "openoffice.org" (No such file or directory)"
> The command the shortcut references is:
> openoffice.org -writer %U

To fix this, I run gconf-editor, then under apps->panel->objects I
change the .desktop file that the panel icons point to by selecting
the key that specifies which .desktop file to launch and changing the
name, for instance, from openoffice.org -writer %U to openoffice.org3
-writer %U .... it should also be possible to just go to the
/usr/share/applications directory and rename
openoffice.org3-writer.desktop to openoffice.org-writer.destkop (for
instance) and have everything work as well.   I also set the icons to
"Mandatory" using the gconf-editor GUI to force these panel objects to
show up always.  If you can't tell, I really like gconf-editor and
what it can do (like setting the http_proxy setting and other
system-wide settings in addition to apps)

> The second problem is a bit more crucial -- the whole reason I was not
> able to just stick with the stock CentOS 5.2 version of open office is
> because of its inability to deal with *.docx files.  After
> installation of the most recent version (OO help indicates that it is
> indeed version 3) everytime I try to open a MS office 2007 docx file,
> Open Office crashes.  I've tried several different types of files, and
> each time it does the same thing -- crashes, restarts, attempts to
> recover.

I have opened several .docx files with OOO3 without issues using both
the 32- and 64- bit versions of OO.org3.  I've also added the pdf
import extension and used it.  If these aren't working correctly, try
quickly uninstalling OO.org3 (I use yumex, use openoffice as a filter
and unselect all the openoffice packages. Then, cd to the OO.org3
installation directory and re-run the ./setup script (on 32-bit), I
unselect the online-update option since that has caused issues for me.
Finally, I re-run the script to install all the Microsoft fonts to
make certain they are installed, and then run spadmin to add some more
fonts that we have locally.

Dave Hopkins
Newark Charter School
Newark Delaware

More information about the K12OSN mailing list