[K12OSN] Blender as a Local App

Stephen Crampton SteveSings at gmail.com
Sun Jan 4 18:06:23 UTC 2009

I have powerful thin-client machines, so I would like to run Blender 2.48a
as a local app.  (I want to use LTSP because I don't want disk drives in the
clients; I want them all to network boot.)

I've done a lot of research and tried a number of different approaches.  I
would really appreciate any advice anyone could give me.  Here is a summary
of my attempts:

1) I tried installing the new beta K12Linux onto an extra server machine.
When I tried to boot thin clients, the X server on the clients crashed after
entering a username and password at the login screen.  Although K12Linux
promises to make it easy to customize your thin-client environment, I'm not
sure it's compatible with my equipment.

2) I tried copying a 32-bit version of Blender 2.48a to /opt/ltsp/i386/.
Then, I chrooted to /opt/ltsp/i386.  Then I tried running blender.  It
complained that it wanted libPython, so I created a folder
(chroot)/blender/lib and did "export LD_LIBRARY_PATH=/blender/lib."  Then
(from outside the chroot) I put i386 python libraries in

Running blender again (in the chroot), it wanted SDL.  I hunted down the
libSDL files and put them in /blender/lib.

Then, blender wanted GLIBC_2_3_4.  I tried copying different versions of
glibc-2.x from the /lib and /usr/lib folders in the rpm archives for glibc
to /blender/lib.  With more recent versions, I got an error regarding TLS.
With older versions, I got a cryptic error regarding ld_linux.

I gave up this approach because my intuition is that there are some
fundamental incompatibilities between the libraries in the chroot
environment and the blender binary.  Please let me know if you think I'm
wrong about this and have any suggestions.

3) I tried building the LBE per the instructions at
http://wiki.ltsp.org/twiki/bin/view/Ltsp/Build-LTSP-42  At first, I was
stymied by the lack of an appropriate gcc, but then I installed the "Legacy
Development" group under the Fedora Package Manager.  It appears to have
installed gcc-2.3 as an alternate compiler -- yea!

I did "export CC=gcc32" and things were looking real good for a while.  The
./build-all --fetch worked (although I had to grab the sh_utils manually).

Then, I did "./build_all" and it crashed after "Building: glibc".  The
message was "Unable to configure glibc: Inappropriate ioctl for device."
The last few lines of crosscomp-src/glibc/Status/errors said "configure:
error: cannot compute sizeof (long double), 77".

Any advice?

I'm also trying to hunt down a SUSE 9.2 DVD iso, because someone somewhere
said it was a stable environment in which to build the LBE.  Unfortunately,
I've been unable to find the iso anywhere and my torrent for it is stalled
at 0.0%.

My intuition is that continuing to build the LBE is the best approach.
Perhaps I need to set some environmental variables or options to make sure
the build process is only using the legace build environment.

I would really appreciate anyone's help or wisdom or both.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/k12osn/attachments/20090104/7179069a/attachment.htm>

More information about the K12OSN mailing list