[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] The "can't log in as root to fix the 'can't log in as root'" conundrum



So, returning after break I found a problem with my Centos 5 server. It's a K12LTSP 5 EL 32 bit install. I'm not serving thin clients with it, but hope to down the road. I set it up so far to be a Samba/LDAP/homedir server. I fired up the server and then logged into my ubuntu client authenticating via LDAP off the server just fine. I wanted to adjust a configuration on the server so I tried to log in as root at the server's terminal. I got a message saying that it couldn't log in as root because it couldn't find the folder /home/root. This is really odd, because it was working fine before break with the usual /root folder and I never [knowingly] told it to use /home/root for the root folder. Is there someway to log in and tell it to construct a new home folder for root if it can't find one?

I tried logging in via "linux rescue" and I tried to mount the main file system. I was going to change /etc/passwd to have root's homedir be /root but it wouldn't let me mount /dev/sda2 . /dev/sda1 is the boot partition and I'm pretty sure /dev/sda2 is the other stuff. /dev/sda1 stopped mounting on subsequent attempts even after rebooting, really weird. I'm really flummoxed. I don't know how this happened or what to do about it. I can log in as other users just fine on the system, but I need a symlink or something for the /root folder. One other complication is that /home is on a mirrored linux raid partition, so I don't know how to mount that in linux rescue mode, not that I can mount the main partition which isn't on RAID anyway.

Can someone suggest a fix?

Thanks,

ck


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]