[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Open Office problem!



Hello,

I hope everyone is doing well!

I'm *almost* done completely revamping the technology in our
organization and a final hurdle happens to be Open Office.  I hung out
in both #openoffice, #ltsp, and #centos but no solution was found (or
I was met with stony silence in one of the channels).  In any case,
I'm running K12LTSP based on Centos 5.2.  The stock OpenOffice
installation is 2.3 and yum update shows nothing after that available.
 The problem is that Office 2007 docx files are only recognized by OO
ver 2.4 or higher.  I've tried to follow the instructions I've found
online to download the appropriate tar file from OpenOffice, switch
into the RPMS directory and run rpm -Uvh *.rpm.  However, I get an
error as follows:

# rpm -Uvh *.rpm
error: Failed dependencies:
        java-gcj-compat >= 1.0.31 is needed by (installed)
tomcat5-servlet-2.4-api-5.5.23-0jpp.1.0.3.el5.x86_64
        java-gcj-compat is needed by (installed) xalan-j2-2.7.0-6jpp.1.x86_64
        java-gcj-compat >= 1.0.31 is needed by (installed)
xml-commons-apis-1.3.02-0.b2.7jpp.10.x86_64
        java-gcj-compat is needed by (installed)
xml-commons-resolver-1.1-1jpp.12.x86_64
        java-gcj-compat >= 1.0.31 is needed by (installed)
xerces-j2-2.7.1-7jpp.2.x86_64
        java-gcj-compat is needed by (installed) hsqldb-1.8.0.4-3jpp.4.x86_64
        java-gcj-compat >= 1.0.31 is needed by (installed)
tomcat5-jsp-2.0-api-5.5.23-0jpp.1.0.3.el5.x86_64
        java-gcj-compat is needed by (installed) bsf-2.3.0-11jpp.1.x86_64
        java-gcj-compat is needed by (installed) bsh-1.3.0-9jpp.1.x86_64
        java-gcj-compat >= 1.0.64 is needed by (installed)
gjdoc-0.7.7-12.el5.x86_64
        java-gcj-compat is needed by (installed) antlr-2.7.6-4jpp.2.x86_64
        java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
(installed) java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp.112.x86_64
        java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
(installed) java-1.4.2-gcj-compat-src-1.4.2.0-40jpp.112.x86_64
        java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
(installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112.x86_64
        java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by
(installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.112.i386

After that I thought it was some sort of conflict with the existing
open office installation so I yum removed that one, repeated the above
command, and received te same error.  Now I've got NO copy of open
office and I have no idea what to do!

What should I do?

Thank you


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]