[K12OSN] Re: mount: RPC: Authentication error; why = Failed (unspecified error)

Brian Fristensky bfristen at shaw.ca
Sat Jan 10 16:35:57 UTC 2009

> Brian Fristensky wrote:
>> After recent upgrades to my server, my DLW thin client will no longer boot.
>> It seems to load all files by TFTP, but then I get the following messages:
>> Red Hat nash version 6.0.52 starting
>> mount: RPC: Authentication error; why = Failed (unspecified error)
>> nfsmount: error mounting on /sysroot as nfs: Bad file descriptor
>> /setuproot: moving /dev failed: No such file or directory
>> etc......
>> I interpret this to mean that the thin client is trying mount /opt/ltsp/i386
>> as /sysroot on the thin client. the IP of the server is correct.
>> As suggested in a posting about another RPC-related problem:
>>  > /root#/usr/sbin/exportfs -v
>>  > /opt/ltsp         <world>(ro,async,wdelay,no_root_squash,no_subtree_check)
>> I have tried rebooting the server, and even restarting rpcbind and nfs, with no luck.
>> Help would be appreciated.
> Check the /etc/exports file on your server and see if your terminal's IP address is allowed to mount that filesystem.
> -- 
>         "History doesn't repeat itself; at best it rhymes."
>                         - Mark Twain
> | John Lucas                MrJohnLucas at gmail.com               |
> | St. Thomas, VI 00802      http://mrjohnlucas.googlepages.com/ |
> | 18.3°N, 65°W              AST (UTC-4)                         | 

As specified in the LTSP setup instructions, my /etc/exports file contains 
exactly one line:

/opt/ltsp *(ro,async,no_root_squash)

This worked perfectly for several months, and has not changed. Something else
has changed, and since I haven't been playing around with NFS or RPC, I suspect
it occurred as a result of a yum update.

Brian Fristensky
971 Somerville Avenue
Winnipeg MB R3T 1B4 CANADA
bfristen at shaw.ca

More information about the K12OSN mailing list