[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Re: K12ltsp login



On Wed, Jan 14, 2009 at 03:20:06PM -0800, Bob Mead wrote:
> 2009/1/14 Bob Mead <bmead lane k12 or us>:
> 
> >> I'm working on a new k12ltsp 5EL installation. So far I have the server
> >> loaded, its mounting users' /home dirs from a remote machine via nfs,
> >>  authenticating via our remote ldap server (FINALLY!!!, thanks Dan and
> >> others) and now when I login as a user I get "User's $Home/.dmrc file is
> >> being ignored (etc)" I googled the answer to this error and found that I
> >> need to login as me and chmod the permissions to 644. I tried to do this
> >  
> Try adding this to the [security] stanza of /etc/gdm/custom.conf:
> 
> RelaxPermissions=1
> 
> Might also try this in /etc/gdm/custom.conf:
> 
> CheckDirOwner=false
> 
> Do you find any .dmrc files with this command?
> 
> updatedb && locate .dmrc
> 
> 
> Dan Young <dyoung mesd k12 or us>
> Multnomah ESD - Technology Services
> 503-257-1562
> 
> Dan:
> I tried adding the Relax line and restarting gdm - did not fix the problem. 
> I added the CheckDir line and again restarted gdm  (using gdm stop and gdm 
> restart - both of which return "GDM already running. Aborting!" so its 
> probably not working. I ran the update & locate - it found a large number 
> of .dmrc files all except mine being in the user's /home directory. Mine is 
> located in /oldhome and it will not let me copy or move it, seemingly no 
> matter what I do to the permissions or ownership - either as myself or as 
> root. Any further thoughts on what I might try?
> 
The root user may not be allowed to change permissions of the files on an nfs-mounted /home directory.  NFS defaults to the "root_squash" option.  You could try exporting /home with the "no_root_squash" option. 

-Rob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]