[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] RE: K12ltsp login



From: Rob Owens <rowens ptd net>
Subject: Re: [K12OSN] Re: K12ltsp login
To: "Support list for open source software in schools."
	<k12osn redhat com>
Message-ID: <20090115000245 GJ18672 junker owens net>
Content-Type: text/plain; charset=us-ascii

On Wed, Jan 14, 2009 at 03:20:06PM -0800, Bob Mead wrote:

> 2009/1/14 Bob Mead <bmead lane k12 or us>:
>
> >> I'm working on a new k12ltsp 5EL installation. So far I have the server
> >> loaded, its mounting users' /home dirs from a remote machine via nfs,
> >>  authenticating via our remote ldap server (FINALLY!!!, thanks Dan and
> >> others) and now when I login as a user I get "User's $Home/.dmrc file is
> >> being ignored (etc)" I googled the answer to this error and found that I
> >> need to login as me and chmod the permissions to 644. I tried to do this
> >
> Try adding this to the [security] stanza of /etc/gdm/custom.conf:
> > RelaxPermissions=1 > > Might also try this in /etc/gdm/custom.conf: > > CheckDirOwner=false > > Do you find any .dmrc files with this command? > > updatedb && locate .dmrc > > > Dan Young <dyoung mesd k12 or us>
> Multnomah ESD - Technology Services
> 503-257-1562
> > Dan: > I tried adding the Relax line and restarting gdm - did not fix the problem. > I added the CheckDir line and again restarted gdm (using gdm stop and gdm > restart - both of which return "GDM already running. Aborting!" so its > probably not working. I ran the update & locate - it found a large number > of .dmrc files all except mine being in the user's /home directory. Mine is > located in /oldhome and it will not let me copy or move it, seemingly no > matter what I do to the permissions or ownership - either as myself or as > root. Any further thoughts on what I might try?
Dan: I tried changing to relaxpermissions=2 and rebooted, no change. Why does gdm restart (or gdm stop) return "GDM already running. Aborting!" . I tried the gdmflexiserver cmd as detailed in custom.conf, i.e. - gdmflexiserver --command="UPDATE_CONFIG security/Relax Permissions=2" returned 'OK' so I think that got it, but I'm a little confused by the above error(s).

>
The root user may not be allowed to change permissions of the files on an nfs-mounted /home directory. NFS defaults to the "root_squash" option. You could try exporting /home with the "no_root_squash" option.
-Rob

Thanks Rob, that fixed it! Unfortunately it brought up another problem: now my login screen goes blank after I enter my username and password and eventually returns to start all over again, i.e.- asking for username and password. Any help would be greatly appreciated.
Thanks,
	~bob



------------------------------

begin:vcard
fn:Bob Mead
n:Mead;Bob
org:South Lane School District;Technology Services Center
email;internet:bmead lane k12 or us
title:Network Specialist
tel;work:541.762.1124
version:2.1
end:vcard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]