[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Fedora-9 LTSP - Need help with various issues - probably FAQ

John Ellson wrote:
Warren, and others.

Thanks for your guidance.

Some feedback.

First, since there was a suggestion that fc10 might fix some issues and we were expecting to upgrade soon anyway, we decided to go ahead and do it. I have to say that it was not a very satisfactory experience. -Udev or something in fc10 decided to ignore the modprobe aliases and ifcfg-eth* numbering of the interfaces, in particular bridge ports no longer take numbers apparently. So our upstream interface which was eth1 became eth0 and picked up the wrong static configuration, resulting in the server not reappearing on the network.
I misspoke.   eth1 became eth2, not eth0.       "dmesg | grep eth1"  shows:
e100: eth1: e100_probe: addr 0xfd8ff000, irq 20, MAC addr 00:d0:b7:81:c6:46
   udev: renamed network interface eth1 to eth2
Why did udev do this?

Another issue that I forgot to mention is that there are processes left running after a user logs off a client. Is this normal? ellson 3246 0.0 0.0 268756 3236 ? S<sl Jan16 0:00 /usr/bin/pulseaudio --start ellson 3277 0.0 0.0 59676 2192 ? S Jan16 0:00 /usr/libexec/pulse/gconf-helper


- Yum or rpm, or anaconda, failed to upgrade a number of rpms which were the same version number, but just fc10 instead of fc9. Its as if some version comparison routine isn't seeing 10 > 9 ? This definitely broke cups until I manually upgraded the rpms using --oldpackage. It may have broken other things too as I'm still looking for fc9 rpms that are not in fc10 (difficult because the fc10 distro does contain some fc9 rpms). - The kernel, or xorg, failed to properly configure the resolution of some client monitors that had worked fine in fc9. It would show the login screen at twice the proper size so that we could only see half of it. We discovered that it was related to the use of VGA cables on radeon3200 graphics cards. Switching to DVI cables where possible seems to fix it, but now we have to replace a couple of VGA-only monitors to get back to where we were with fc9.

We have a new problem with nautilus and bonobo on the (slower?) i386 clients. The nautilus desktop icons appear to flash up briefly before the desktop appears, then the desktop shows no icons and an error popup: "Nautilus cannot be used now due to an unexpected error from bonobo when attempting top locate the factory. Killing bonobo-acticvation-server and restarting nautilus may help fix the problem." Killing bonobo-activation-server doesn't seem to have any effect, but starting nautilus from a shell woks, except that we really can't expect the elementary kids to do that.

Fedora 10 has made client sound worse. We used to hear very quiet sounds, now nothing. In /var/log/messages I see stuff like: Jan 15 18:26:23 sol pulseaudio[2806]: polkit.c: Cannot set UID on session object
Jan 15 18:26:23 sol pulseaudio[2806]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges: Jan 15 18:26:23 sol pulseaudio[2806]: main.c: We are not in group 'pulse-rt' and
PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jan 15 18:26:23 sol pulseaudio[2806]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user. Jan 15 18:26:23 sol pulseaudio[2806]: pid.c: Stale PID file, overwriting. Jan 15 18:26:23 sol pulseaudio[2806]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted Jan 15 18:26:23 sol pulseaudio[2806]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

USB memory sticks are no better. When we plug one in nautilus shows the mount, and the folder can be opened seeing file and directory icons, but the files can't be read. For example, clicking on an image produced an error from eog: "error reading from file, cannot allocate memory" I saw your note indicating that this was handled by "gvfs", OK, so where do I look for gvfs problems?

Is it possible that both USB and sound problems are authentication related? Does the upgrade process even attempt to migrate for new authentication requirements? Is there a guide specifically on authentication set up, or better yet, an audit script to suggest what might need changing?

Thanks for the pointers to latest howto <http://wiki.ltsp.org/twiki/bin/view/Ltsp/LtspDocumentationUpstream> and the technique for upgrading kernels in the chroot images. Can I suggest that a paragraph on chroot updates, and a link to the larger howto be added to https://fedorahosted.org/k12linux/wiki/InstallGuide ? I really like that page as a one-stop quickstart for ltsp on Fedora.

I haven't had a chance to retry local apps.


Warren Togami wrote:
John Ellson wrote:
- Sound "works," if the classroom is silent and you have very good ears! How do I increase the volume on all clients to a useful level?
  In /var/lib/tftpboot/ltsp/*/lts.conf we have:
There was recent discussion, for Ubuntu, at: http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2008-08/msg01267.html
  should I be trying to apply this?

I have noticed this as well. I am digging into this sometime soon myself.

- If I plugin a USB memory stick in the client, I get an icon on the desktop, which I can open with nautilus, but none of the content is shown? Where do I look next?

I have never seen this personally, although I haven't used F9 for a few months now. Could you please try booting your server with the K12Linux F10 Live Server and see if the clients behave the same there?

- Where is the FAQ on how to update the client images properly? I tried using yum in the chroot, but kernel updates didn't work, so now I'm rebuilding the client images from scratch periodically.

After updating the kernels in the chroot, did you use "ltsp-update-kernels" outside the chroot to copy the kernel from inside the chroot to /var/lib/tftpboot/ARCH/?

- Where is the step-by-step FAQ on configuring and installing local apps?

Umm... upstream should have this documented, if not please yell at them. The only thing unique about our local apps installation is yum instead of apt.

- Are last-modified-in-2004 FAQs like the one at: http://ltsp.mirrors.tds.net/pub/ltsp/docs/ltsp-4.1-en.html still accurate? I assume that the current documentation is supposed to be at https://fedorahosted.org/k12linux/, but there seems to be a lot missing there.

Could you please make a list of specific documentation items you really need rewritten for K12Linux? The old docs are so old that it would be better to write them from scratch.

Warren Togami
wtogami redhat com

K12OSN mailing list
K12OSN redhat com
For more info see <http://www.k12os.org>

John Ellson

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]