[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] NFS Install



Barry R Cisna wrote:
Jim,

You didn't mention what Linux distro you are running the nfs server
on?

Fedora 10.

If it is a default install of EL5 try changing your nfs syntax to nfs3/IPv4. Something like this; /iso
192.168.0.0/255.255.255.0(ro,sync,no_root_squash)

,,then 'service nfs restart'

Then try and do your nfs install. Also make sure your nfs server is
not on a different subnet that the actual server you are wanting to
install onto,is. You can run into troubles going across a
router(sometimes) with nfs installs. Let us know your progress.

The install-machine was indeed on the same network as the nfs server.
Indeed, they were on the same switch.

David L. Willson wrote:
I don't think it works to export the ISO as a file.  I think you have
to mount the ISO, or the CD, or copy all the files, and export the
actual files from the ISO to do an NFS install.  But, that's not
what's preventing the NFS mount.

The Centos documentation says it should work. I tried it the other way too - two ways in fact. I first mounted the .iso file to /mnt/iso. When I did that, I was able to mount the nfs export with a third linux box (Fedora 8, I believe). It was able to list the contents of the iso, showing the Centos and images directories (et al) as well as the RELEASE-NOTES*.html files. When that didn't work, I mounted the iso elsewhere and copied everything to /mnt/iso. Same results.


You've tested mounting this export from other NFS clients.  Can you
list the contents of the export from a successfully connected NFS
client? For example: # mount spiff:/mnt/iso /mnt # ls -al /mnt

What's that get?

And when you do your mount from the installer, what information are
you providing in the NFS dialog?

For the ip address, I gave it the ip address of the nfs server. For the mount point, I told it "/mnt/iso". I also tried "/mnt/iso/" with the trailing slash. Neither of these included the quotes.

I'm at home right now, and my new server is at the office. I do have my nfs server (which is my laptop) with me right now, and I have two other Linux machines here in the house at my disposal.

Unfortunately, neither of these other two linux boxes are 64-bit machines. :-( So... I'll try again tomorrow.



--
Jim Thomas            Principal Applications Engineer  Bittware, Inc
jthomas bittware com  http://www.bittware.com    (603) 226-0404 x536
Hope springs occasionally.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]