[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fwd: [K12OSN] RE: K12ltsp login]



Hi Bob,

I've seen all the messages on the list. I think nobody had a quick answer.

--
Dan Young <dyoung mesd k12 or us>
Multnomah ESD - Technology Services
503-257-1562



2009/1/21 Bob Mead <bmead lane k12 or us>:
> I tried to send this three times yesterday, never did see it come up on the
> list. Any ideas why not?
>
> I did remove the no_root_squash option from my /etc/exports file and
> restarted the nfs daemons (portmap, nfs-common and nfs-kernel-server in
> that order). Just to be sure, I restarted the k12ltsp server, and I get
> the same results - i.e.- after I enter my user name and password the
> login screen goes blank and eventually returns to the login screen again
> asking for my username. ???
>
> So I've conquered the .dmrc problem, got the ltsp box (apparently)
> talking to the ldap server, successfully remote mounting users /home
> directories via nfs and yet I still cannot login.
>
> Does anyone have any further ideas on how to make this work? I'm still
> thinking along the lines of somehow tracking the authentication requests
> to the ldap server to see if I am getting that far. And if I am, how are
> those requests being handled by the ldap server?
>
> I'm starting to get anxious about the amount of troubles I am having
> getting this to work. Perhaps last week's posts re: the complexity of
> linux and ltsp REALLY are worth paying some attention to...
>
> Thanks in advance for any help!!
>     ~bob
>
> Rob Owens wrote:
>>
>> On Fri, Jan 16, 2009 at 10:52:09AM -0800, Bob Mead wrote:
>>
>>>
>>> From: Rob Owens <rowens ptd net>
>>> Subject: Re: [K12OSN] Re: K12ltsp login
>>> To: "Support list for open source software in schools."
>>>        <k12osn redhat com>
>>> Message-ID: <20090115000245 GJ18672 junker owens net>
>>> Content-Type: text/plain; charset=us-ascii
>>>
>>> On Wed, Jan 14, 2009 at 03:20:06PM -0800, Bob Mead wrote:
>>>    The root user may not be allowed to change permissions of the files on
>>> an nfs-mounted /home directory.  NFS defaults to the "root_squash" option.
>>>  You could try exporting /home with the "no_root_squash" option. -Rob
>>>
>>> Thanks Rob, that fixed it! Unfortunately it brought up another problem:
>>> now my login screen goes blank after I enter my username and password and
>>> eventually returns to start all over again, i.e.- asking for username and
>>> password. Any help would be greatly appreciated. Thanks,
>>>        ~bob
>>>
>>>
>>
>> I don't know why that would happen, but...
>>
>> If you have completed all the permissions/ownership changes that you think
>> you need, and you don't need to create users' home directories on login,
>> then you may no longer need the "no_root_squash" option.  I don't think that
>> option is required for "normal" LTSP usage.  Try removing that option and
>> restarting the nfs server, then see if your server behaves normally.   Note
>> that in the future instead of setting the "no_root_squash" option to change
>> permissions on the nfs mounted files, you could ssh into the nfs server as
>> root and change them there.
>>
>> -Rob
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>>
>>
>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]