[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] No sound after moving to FC10



> When the clients boot up,do you ever see any lines in regards to
"loading sound
> module xyz failed", (shortly before the Xconfig stage)?

I didn't see any such message, but with FC10 I now see a fancy set of 
graphic bars on
the bottom of the screen for most of the boot process rather than anything
useful.
When I switch to the console output during that phase of boot I see
nothing of note,
and no errors.  Not much is displayed, though.

> Also on a client if you drop to a shell and run ' lspci' do you see any
soundcard
> resemblance listed? I assume these are the exact same clients that DID
work on
> your earlier versions of k12ltsp?

Yes -- the hardware is exactly the same -- with no changes whatsoever.

> Let us know maybe a few more details on what the clients actually are?

If I drop into a shell in the GUI (running on the server) I see this in the
lspci output:
> 01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

On the client machine, dropping into a local shell I see this from lspci:
   00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
   01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

All worked fine with regard to sound under FC9 until, as I mentioned the
other day,
we applied some update.  At that point sound became attenuated and was barely
audible.  Unfortunately, we didn't notice this right away and don't know
what the
offending update was.  Under FC10 we get no sound at all.

The hardware for the server and most of the clients is a Gigabyte
GA-MA78GM-S2H motherboard with 2gb of RAM and a dual-core CPU. Everything
is integrated onto the motherboard.  It has RealTek hardware for sound.
I found references to it needing an ALC889 driver, however on the client
machine I see this in the dmesg output:

   hda_codec: Unknown model for ALC883, trying to auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:3303:  autoconfig: line_outs=4
(0x14/0x15/0x16/0x17/0x0)
   ALSA sound/pci/hda/hda_codec.c:3311:  hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3312:  mono: mono_out=0x0
   ALSA sound/pci/hda/hda_codec.c:3320:  inputs: mic=0x18, fmic=0x19,
line=0x1a, fline=0x0, cd=0x0, aux=0x0

Our 32-bit clients are mostly old Compaq machines, but they, too, fail to
have any sound.
Running dmesg on them reveals nothing of note.  I'm not too worried about
sound on them,
as we're going to be replacing them fairly soon.  I believe they have AC97
hardware as
there was reference to that on one set of 32-bit client dmesg output that
was unrelated
to sound:

   intel8x0_measure_ac97_clocl: measured 50714 usecs

At shutdown I see this on the all clients, but I don't think it means
anything is wrong:

   Saving mixer settings /sbin/alsactl: save_state:1541: Cannot open
   /etc/asound.state for writing: Read-only file system

> You didn't mention what your previous version of k12ltsp,that you were
> running that these clients did have sound on. My guess would be that

As of this morning we're on ltsp-server-5.1.54-1.fc10x86_64 (I think that's
what you want).

> for whatever reason,the clients sound cards would set up correctly with
esound as
> the sound daemon. When using pusleaudio,things get initialized a bit
different. I
> know this is not a resolve for you,but that would be just a guess what
has gone
> south on you.
> What do you get when you try and run the SYSTEM>Preferences>More
> Preferences>Mulitimedia Systems Selector>Default Output Plugin,>Test?

I have no such menu option.  Trying System->Preferences->Hardware->Sound I
find
that the system does in fact play a very faint tone.  It does this with
either
of these drives selected:
   PulseAudio Sound Server
   ALSA - Advanced Linux Sound Architecture
   Autodetect (which clearly selects one of the previous two)

This is the *only* time I hear anything from the speakers. All the volume
controls are set to 100% and all system sounds are turned on.  Perhaps
sound is
working and it is at so low a volume that it can't be heard other than via
this
utility?  Does the utility do something to play sound that the rest of the
system
doesn't do?  Maybe this morning's update of ltsp-server to the above-version
fixed something?  Sound is still not working, though, as nothing is
audible via
any application except the test utility.

reb







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]