[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Where is K12LTSP at?



Finally, I managed to find the right google search.  The issue is a
bug in mkinitrd and how it handles i2o controllers.  A bug report has
been submitted now twice on this issue.  I don't know who has the
'pull' to actually get this resolved but the bug is
https://bugzilla.redhat.com/show_bug.cgi?id=476277

I spent all day trying to resolve this with various options to
mkinitrd (even using a version posted here:
https://bugzilla.redhat.com/attachment.cgi?id=330620 ) which has the
same bug.  Seeing as how simple it is to fix this bug (you make two
very simple changes as shown below ) I would hope it actually makes it
into the next patch of mkinitrd.  Anaconda works but mkinitrd fails.

>From the prior bug report by   Hibbard T. Smith, JR
----------------------------
diff -cr mkinitrd-6.0.71/mkinitrd mkinitrd-6.0.71-patched/mkinitrd
*** mkinitrd-6.0.71/mkinitrd	2008-11-12 14:02:43.000000000 -0500
--- mkinitrd-6.0.71-patched/mkinitrd	2008-12-12 13:47:05.000000000 -0500
***************
*** 191,198 ****
      fi

      # special cases
!     if [ "$modName" = "i2o_block" ]; then
!         eval $subcmd i2o_core
          eval $subcmd -i2o_pci
          modName="i2o_block"
      elif [ "$modName" = "ppa" ]; then
--- 191,198 ----
      fi

      # special cases
!     if [ "$modName" = "i2o_core" ]; then
!         eval $subcmd i2o_block
          eval $subcmd -i2o_pci
          modName="i2o_block"
      elif [ "$modName" = "ppa" ]; then
------------------------------------------------------------------------

Sincerely,
Dave Hopkins



On Sat, Mar 7, 2009 at 1:55 PM, David Hopkins <dahopkins429 gmail com> wrote:
> And ... another update.  I downloaded the DVD and ran the install.
> After installation, I get
>
> unable to access resume device
> error mounting dev root on sysroot as ext3
>
> Which apparently seems to be related to mkinitrd being screwed up
> during an update?  My swap has the UUID=LONGSTRINGOFCHARACTERS issue.
>
> A bug report for this is https://bugzilla.redhat.com/show_bug.cgi?id=471729
>
> I am still waiting to see if a yum update followed by a rebuild using
> the updated mkinitrd will fix this.
>
> So far with all these issues I have spent many many more hours than I
> had planned and I'm still not even close to sorting out if local apps
> will even work for me.  Seems to be issues there are well according to
> what I can find on the wiki.  I'd be ecstatic if there is a simple
> description of how to get local apps working (and verified).
>
> Sincerely,
> Dave Hopkins
>
> On Fri, Mar 6, 2009 at 2:43 PM, David Hopkins <dahopkins429 gmail com> wrote:
>> And another update. Clicking on Install to Hard Drive and the
>> installation hangs at "Performing post-installation filesystem
>> changes"  I have let it run for 2 hours at this point.  Any ideas?  If
>> not, I'll download FC10 installation CD/DVD and run the install that
>> way, then add the LTSP stuff, and finally add the K12LTSP packages.
>>
>> Sincerely,
>> Dave Hopkins
>>
>>
>> On Fri, Mar 6, 2009 at 10:09 AM, David Hopkins <dahopkins429 gmail com> wrote:
>>> Revisiting this with an update.
>>>
>>> I was able to boot my x86_64 servers via the USB LiveServer but had a
>>> couple of glitches.
>>>
>>> 1) I don't allow DHCP on the switch that the servers share, so I
>>> disabled Network Manager and manually assigned the IP address, subnet
>>> mask, gateway.  Tested by pinging various systems within the network.
>>> 2) Configured the second ethernet card to serve the clients. Booted a
>>> few different types of hardware and they seem to work.
>>> 3) But ... web browsing did not work. I have to use a proxy and after
>>> setting the proxy setting (either at the console for liveuser or at a
>>> thin client with either liveuser or a test account) I get an error
>>> message that FF is configured to use a proxy and the connection is
>>> being refused. Very strange as I obviously don't have that issue with
>>> the current release.
>>> 4) Sound seemed to work but until I can get FF to proxy correctly, I
>>> can't test the ability to use what-used-to-be UnitedStreaming or other
>>> video/audio repositories.
>>>
>>> And ... any documentation on the new locations of all the config
>>> files?  This has changed.  Ideally I will be changing the ltsp
>>> settings back to the 192.168 address range so I don't have to change
>>> all my pre-defined thin clients as well as printers.  It should be 1
>>> or 2 files that have to be edited (dhcpd.conf would be one?)
>>>
>>> Thanks!
>>> Dave Hopkins
>>>
>>>
>>> On Tue, Feb 24, 2009 at 3:21 PM, Warren Togami <wtogami redhat com> wrote:
>>>> David Hopkins wrote:
>>>>>
>>>>> I am using the Centos5 version on all my servers (6 LTSP servers, 200+
>>>>> thin clients, 4 other servers at present). I know I am not getting the
>>>>> latest/greatest that LTSP provides but I've also seen people reporting
>>>>> issues and I just haven't had the time to sort out if K12Linux will
>>>>> run on the thin client hardware that I have available.  In particular,
>>>>> I have a lot of Via EPIA 533-based thin clients that the school
>>>>> purchased.  These have to work or else I cannot justify the switch.
>>>>
>>>> https://fedorahosted.org/k12linux/wiki/LiveServer
>>>> Tried this?  K12Linux Live Server media will allow you to try K12Linux in
>>>> demo mode with your existing network of thin clients, without risking the
>>>> hard drive of your server.
>>>>
>>>>> However,  the only real driving reason for me to upgrade is to
>>>>> finally, once-and-for-all, get sound working properly with support for
>>>>> local microphones as well.  That is the driving issue for me (and if
>>>>
>>>> Last I heard none of the distributions of LTSP5 have microphones working.
>>>>  This might be mainly an issue of nobody working on it yet though.
>>>>
>>>> Warren Togami
>>>> wtogami redhat com
>>>>
>>>> _______________________________________________
>>>> K12OSN mailing list
>>>> K12OSN redhat com
>>>> https://www.redhat.com/mailman/listinfo/k12osn
>>>> For more info see <http://www.k12os.org>
>>>>
>>>
>>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]