[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] correct repo for K12ltsp 5 Centos?



Scott S. wrote:
Hi all, I have an install that hasn't been updated for some time. It is on dialup, and over time has had several additional things installed. The prospect of a fresh install and copying /home over is daunting, due to the things I have installed.

I recently took the server to my work's network, thinking I would upgrade everything. The existing repo was no longer in place. After some searching, There was originally a (now) invalid mirrorlist, I decided on the following for my k12ltsp.repo entry in /etc/yum.repos.d

baseurl=http://k12linux.mesd.k12.or.us/K12LTSP/5.0.0-EL-32bit/i386

I chose gpgcheck=0 because I figured the gpgkey URLs were invalid as well.

Now, yum can find the repo and update the package list. I cannot however do a system upgrade, it fails (I do not have the exact error). I can however manually yum upgrade <packagename> with this list in place.

Questions:
1. What is a valid 'mirrorlist' parameter
2. Can I save this installation without starting over? Everything is working well.

Here is the output of uname -a

Linux bofh2.ltsp 2.6.18-128.1.6.el5 #1 SMP Wed Apr 1 09:19:18 EDT 2009 i686 i686 i386 GNU/Linux

Mine has:
mirrorlist=http://k12linux.mesd.k12.or.us/mirrors/k12ltsp-5.0EL-$basearch

You should expect an error. There is a conflict where one of the Centos update rpms has added a file named /etc/udev/rules.d/99-fuse.rules which was already included in a k12ltsp package (this is always a risk when using 3rd party repositories).

A workaround is described here:
http://www.redhat.com/archives/k12osn/2009-October/msg00121.html


--
  Les Mikesell
   lesmikesell gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]