[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fwd: Re: [K12OSN] yum update vs. /etc/udev/rules.d/99-fuse.rules



Hi,

We followed the same process below and was able to get fuse installed successfully. However, after the installation, we get a serious error with yum that prevents us from progressing with installing the packages:

[root server rules.d]# yum update
Loading "installonlyn" plugin
Options Error: Error parsing '1h': invalid integer value
This is the original error we got after doing a clean install of K12LTSP and attempting a yum update:

Transaction Check Error:
 file /etc/udev/rules.d/99-fuse.rules from install of fuse-2.7.4-8.el5 conflicts with file from package ltsp_config-0.0.42-k12ltsp.5.0.0EL


What you do is rename the 99-fuse.rules file to, say, 99-fuse.rules.bak and then go to /var/cache/yum/k12ltsp/packages.  Do an "rpm -Uvh --force" on whatever package it is that wants to install a new 99-fuse.rules (it starts with "fuse").  Then, once you're done, you should have both 99-fuse.rules (from the new CentOS 5.4 fuse package) and your .bak version from the ltsp-something package.

Give your system a test drive w/ a thin client.  If you're doing local floppies or something similar, be sure to try that out.  If things are continuing to work just fine, then leave things as they are.  If not, then just rename the new 99-fuse.rules file to 99-fuse.rules.rpmnew or something like that, and rename your "old" one from the ltsp-something package to 99-fuse.rules.

~~~~~~~~~~~~~~~~~~~~~~~
Alan Owen
Assistant to the Director of Information Services
Hermon Information Services/Hermon School Department
"Using Technology to Empower All Students to Succeed in a Changing World."
~~~~~~~~~~~~~~~~~~~~~~~


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]