[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Anyone know how to solve this yum error?



Carl Keil wrote:
I ran "yum clean all" and then "yum update" and obtained the following after all the downloading and transaction checking...

Transaction Check Error:
file /usr/lib/libgcrypt.so.11 from install of libgcrypt-1.4.4-5.el5.i386 conflicts with file from package libgcrypt11-1.4.0-15.el5.i386

I've tried googling many times and couldn't find any advice that helped with this problem. How can I get my server to update?

I don't think I've seen anything about a problem like that. How long has it been since updates succeeded?

I'd try:
yum update glibc\*
yum update rpm\* yum\* python\*

and try again. If it still doesn't work, try:
yum install yum-downloadonly
yum --downloadonly install libgcrypt
then go find the downloaded rpm (somewhere under /var/cache/yum) and see if you can get rpm to update it or at least get a sensible error message about why this isn't a simple update.

--
  Les Mikesell
    lesmikesell gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]