[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] users not logging into my thin client environment



LTSP in the classroom also takes a shift in how a teacher restricts or
monitors what goes on in their lab.  One of the beauties of the LTSP
environment is that if every student has an individual log in, they
can change their background, their home pages, add icons to the
desktop, choose their windows manager (KDE, Gnome, xfce if you've
chosen to install them).  Not having to restrict this and monitor
technology actually frees an instructor up to focus on teaching
technology rather than spend time monitoring it.  If a kid messes up
their Gnome configuration, delete the Gnome configuration file in
their home folder and they're fixed.

It took me a little while to adjust to the different way of thinking,
but it was very freeing to me and my students.

That's my opinion anyway.

Enjoy,
Eric

On Wed, Apr 28, 2010 at 8:15 AM, Peter Scheie <peter scheie homedns org> wrote:
> I think you misunderstand how LTSP works.  The applications that users run
> actually run on the server.  The client environment is only used to
> *display* the applications that are running on the server. An LTSP client is
> sort of like a remote console.  You can designate individual applications to
> be run locally on the clients, but this is not the default. If you truly
> want the clients to be running stand-alone environments, you might look at
> DRBL (Diskless Remote Boot Linux).  But make sure your clients are up to the
> task.
>
> Peter
>
>
> Mathieu Pelletier wrote:
>>
>> So, I have successfully set up my LTSP server and the clients boot
>> successfully.  I have even changed the default LDM theme and it looks
>> brilliant!  But now, I have a small problem that my users upon logging in
>> are not in the LTSP environment (the one in /opt/ltsp/i386).  They are
>> actually logged into the server environment.
>> My server is running F13 and my thin client environment image is F12
>> (since the F13 ltsp enviro wasn't building and due to stability on the
>> client).  Anyway, everything seems to be working great on the client in
>> spite of this.  I do, however want my users to be using the proper
>> environment, since my changes and customisations for that image needs to be
>> replicated to the client, and obviously the users do not need all the
>> services on the server's image.
>> My question is how do I remedy this so that users login to the correct
>> environment.  The login screen is taken from
>> /opt/ltsp/i386/usr/share/ldm/themes, but once the user logs in they have the
>> F13 background and everything.  It seems to me that the solution should be
>> pretty easy, but I have not found much information on how to properly
>>  create user accounts.  I have the users home directory mounted in
>> /opt/ltsp/i386/home/username, so this part is working.
>>
>> ~Thanks for your help!
>>
>>
>> --------------------------------------------------------------------------------
>> Mathieu Pelletier
>> Director of IT Development
>> Theological College of Zimbabwe
>>
>> Tel: +263 9 287032/3  Ext: 214
>> mpelletier tcz co zw <mailto:mpelletier tcz co zw>
>> www.tczonline.com <http://www.tczonline.com>
>> Chat Google Talk: mkpelletier Skype: mathieu.pelletier
>>
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]