[K12OSN] SOLVED: Fresh install of F12 w/ updates and problem running ltsp-build-client

Jeff Siddall news at siddall.name
Wed Jan 20 14:54:35 UTC 2010

On 01/15/2010 04:10 PM, Jeff Siddall wrote:
> Dan Young wrote:
>> On Fri, Jan 15, 2010 at 7:01 AM, Jeff Siddall <news at siddall.name> wrote:
>>> Almquist Burke wrote:
>>>> On Jan 14, 2010, at 2:57 PM, Jeff Siddall wrote:
>>>>> Anyone have success with F12 and ltsp-build-client yet?
>>>> I didn't have any problems with it. Are you working from a fresh install?
>>> No, this is an upgrade from an F10 K12Linux install.  The script was
>>> flaky there too, though occasionally it did complete successfully.
>>> Maybe a timing issue or something?  I dunno.
>> Can you "rpm -V ltsp-server"? Maybe your kickstart file that the ltsp
>> client builds from is goobered.
> rpm -V ltsp-server
> shows:
> S.5....T.  c /etc/ltsp/ltsp-build-client.conf
> S.5....T.  c /etc/xinetd.d/nbdrootd
> S.5....T.  c /etc/xinetd.d/nbdswapd
> .......T.    /usr/sbin/ltsp-build-client
> S.5....T.  c /var/lib/tftpboot/ltsp/i386/lts.conf
> I changed the cache setting in /etc/ltsp/ltsp-build-client.conf, I have
> a customized /var/lib/tftpboot/ltsp/i386/lts.conf and I tried some debug
> commands in /usr/sbin/ltsp-build-client so those are expected.  I am not
> sure why the other files are different.
> rpm -qf /usr/sbin/ltsp-build-client
> revealed:
> ltsp-server-5.1.95-1.fc12.i686
> So that all looks OK.
> Any other ideas?

UPDATE: Henry suggested I disable nscd while running ltsp-build-client
and it worked!  There were some other errors like:

sh: /usr/sbin/setenforce: No such file or directory


sed: warning: failed to set default file creation context to
unconfined_u:object_r:usr_t:s0: No such file or directory...

but the bottom line is:

info: LTSP client installation completed successfully

I'll try booting  it on a client sometime this week and make sure
everything is OK.


More information about the K12OSN mailing list