[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Yum transaction hangs-Centos



I have a Centos LTSP install that is my home/test bed. I have used LTSP for a long time, I chose the Centos variant for my home use, because at the time I only had dialup. Upgrades were a matter of hauling the server to someplace with a fast connect.

I haven't done that for almost a year, and just got DSL at home. Gleeful at the prospect of easily updating, I am running into failed yum transactions. I noticed this a while back when I tried to update cups. It suggested I run yum-complete-transacton, which also just hung. That process borked cups, but I could put it back from a backup easily.

I ran 'yum clean all' with no change.

In googling the problem I could see that this can be caused by hung nfs mounts. I have an nfs mount (that has been working fine), but i unmount -f it just in case.

The kernel is 2.6.18-128.1.6.el5

The problem is happening either with the command line yum or Yumex. Yumex's plugins are fastestmirror and priorities.

While I have used other 3rd party repos over the years (Adobe, rpmforge, livna, etc), my current repos are:
CentOS-5- Updates
CentOS-5-Extras
CentOS-5 Addons
CentOS-5-Base
k12ltsp

Suggestions?
TIA-Scott S.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]