[K12OSN] LTSP - No clients can connect!

Phydeaux reb at taco.com
Sat Oct 30 21:32:53 UTC 2010

> What version of ltsp are you running,on top of FC13? I have always done
> the full K12LTSP installs since it's inception way back. I am sure there
> is some behinds the scenes quirks that may be slightly different between
> versioning numbers, and actual OS's etc.

I'm not sure exactly what is installed, but I'm pretty sure it's the
standard set of ltsp packages, the same as you.

> I am probably wrong but I think in your tcp returns of nmap you should
> at least have port 6001 = X11 and , 7100 = font-service in order for
> TC's to negotiate as expected,although you said some clients are
> A-OK?...Your nmap returns are not showing these two ports listening?

Well, we've fixed things -- and nmap is still not showing those ports

> What do see when you run on the server 'tail -f /var/log/messages' and
> boot a thin cleint ?
> Do you have SELinux disabled as well?

We're running SELinux...

We did figure out what was wrong.  We have all of the clients connected
via 1GB Ethernet on a private LTSP lan with its own 1GB switch. For the
"outside" network that the LTSP server connects to the Internet over,
that hosts our network printers, and that the office uses, we have a
10/100 switch.  While exhausting all the options we could think of to
fix the software, I noticed that some clients would complain about the
network not being available and not getting IP addresses assigned by
DHCP.  Changes in the DHCP issue seemed to be independent of any of
the software changes we were making.

On a hunch, I disconnected everything from the 10/100 switch and moved
all of the connections from the 1GB switch to it.  After further
testing, we also moved the server's LTSP connection to a spare 10/100
Ethernet port we had available.  Lo and behold, everything worked.  A
quick trip out to some local stores netted us a replacement 1GB network
card and a replacement switch.

At least we ended up with the clients at FC13.  We also got the USB
problems on the client partially solved.  The clients seem to be able
to use USB flash drives just fine when in 32 bit mode. They still do
not work on x86_64 clients.  For now we're just having everything
boot as a 32 bit client.  Nobody except the sysadmins knows or cares
about that distinction.

Thanks for the advice!


More information about the K12OSN mailing list