[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] How to update K12LTSP-5.0.0EL-32bit chroot

got you. thats what i was doing with the f10 prebuilt chroot. just
renaming the original ltsp and dropping the f10 one in. i did the same
with the kernels under tftpboot.

it seems like thefed ltsp root work alot differently. unlike the centos
root, i could see fed10 aquiring the image on the desired port 1067,
load, then make a second dhclient call back to standard 67. i managed to
get that squared away , telnet worked but x was broken.  got x working
but ldm wasnt loading.

put that aside, got a pristine cent ltsp box back up moved moved most of
lib   lib/modules lib/udev /usr/lib from the fed root in,  kept existing
X and shell scripts and binaries. might be missing a couple of things.
tc came up without error. basic functionality ok. ran scanimage from tc
shell, not perfect but it saw the device and pulled the paper thru on
the old scanner. gonna bolt this on top of my kickstart, load the
sane-backend required for the new scanner and see what happens.

On Wed, 2011-02-09 at 16:15 -0500, Terrell Prude' Jr. wrote:
> Not exactly.  I'm suggesting that you backup the existing /opt/ltsp/i386
> subdirectory, or just rename it.  Then, from your K12Linux Fedora
> 9/10/11/12/13/14/WhateverYouChoose box, copy *that* /opt/ltsp/i386

> subdirectory tree--the entire thing--over to your K12LTSP 5EL server.
> Your clients will thus be using that Fedora version of the client
> binaries vs. the ones that came with K12LTSP 5EL.
> --TP
> Stephen Kerr wrote:
> > not sure I completely follow.  are you advising to backup the existing
> > directory , drop in the new c libraries (libc)  and see what happens ?
> >
> >
> > On Tue, 2011-02-08 at 19:13 -0500, Terrell Prude' Jr. wrote:
> >
> >> The way I always did it when I needed a specific set of binaries for the
> >> clients was to copy the entire /opt/ltsp/i386 subdirectory (or
> >> /opt/ltsp/ppc, or /opt/ltsp/sparc, as appropriate for my architecture)
> >> to my K12LTSP server.  Beforehand, I would typically rename the existing
> >> /opt/ltsp/i386 subdir. to, say, /opt/ltsp/i386.orig.  These binaries
> >> should have *zero* affect on the server itself, since they run only on
> >> the client.
> >>
> >> Give that a shot and let us know.
> >>
> >> --TP
> >>
> >> Stephen Kerr wrote:
> >>
> >>> Hi Barry,
> >>>
> >>> when i was trying to get my centos host run with a fedora 10 prebuilt
> >>> chroot I had problems with the tc after loading the kernel from my dhcpd
> >>> server on port 1067,  the kernel loaded but the tc was making a second
> >>> dhclient call but back on port 67 and not being able to load a desktop.
> >>> i wound up moving sysinit_early and a couple other files from the centos
> >>> chroot into fed10 prebuilt.
> >>>
> >>>  it then  behaved as it should have more or less. when i was on a telnet
> >>> screen as defined in lts.conf, I was able to login. shell screens give a
> >>> prompt at the TC,  when i specified an x session screen, I had the x
> >>> mouse cursor and gray/silver desktop background.
> >>>
> >>> the K12LTSP-5.0.0EL-32bit iso worked perfectly, my only problem is the
> >>> packages in the chroot are too old. i need to update libc from 2.3.2 and
> >>> i cant find any utility thatll update the chroot so i have been trying
> >>> to adapt ltsp-build-client from fedora, without success , so far.
> >>>
> >>> On Tue, 2011-02-08 at 15:09 -0600, Barry Cisna wrote:
> >>>
> >>>
> >>>> What are you seeing on the TC when it is completely booted up? From what
> >>>>         you explain you are only presented with a telnet login? No other
> >>>>         blinking as if X is trying to start? What have you set in your
> >>>>         lts.conf
> >>>>         file for screens? If you do CTL-ALT-F2 do you get a bash prompt?
> >>>>
> >>>>         Barry
> >>>>
> >>>>
> >>>>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]