[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Frustration with RHEL6.1



I just did a clean install of RHEL6.1 on my server. I did the standard Desktop system
install on an AMD64 workstation.

Is it only me, but has anyone
else had minimal luck installing anything on this platform? It seams like
whenever I try to install software using yum or the GNOME graphical installer,
I get endless dependency errors.

On recent versions of Fedora, yum seemed to always be able to find and
install dependencies automatically. Right out of the box.

This is all relevant to LTSP. I added to following file to /etc/yum.repos.d

[LTSP]
name=Togami LTSP Testing Repo
baseurl=http://mplug.org/~k12linux/rpm/el6/$basearch/
enabled=1
gpgcheck=0
gpgkey=http://www.dageek.co.uk/ltsp/RPM-GPG-KEY-DaGeek-LTSP

and then tried yum install ltsp-server:

... skipping the list of packages to install...

--> Finished Dependency Resolution
Error: Package: 1:python-imgcreate-13.3-1.el6.x86_64 (epel)
           Requires: pykickstart >= 0.96
Error: Package: ltsp-server-5.2.17-1.el6.x86_64 (LTSP)
           Requires: perl(NetAddr::IP)
Error: Package: 1:livecd-tools-13.3-1.el6.x86_64 (epel)
           Requires: syslinux
Error: Package: 1:python-imgcreate-13.3-1.el6.x86_64 (epel)
           Requires: squashfs-tools
Error: Package: 1:livecd-tools-13.3-1.el6.x86_64 (epel)
           Requires: pyparted
Error: Package: 1:livecd-tools-13.3-1.el6.x86_64 (epel)
           Requires: isomd5sum
Error: Package: ltsp-server-5.2.17-1.el6.x86_64 (LTSP)
           Requires: dhcp
Error: Package: 1:livecd-tools-13.3-1.el6.x86_64 (epel)
           Requires: /sbin/extlinux
Error: Package: ltsp-server-5.2.17-1.el6.x86_64 (LTSP)
           Requires: tftp-server
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

As I've said, it's not just ltsp. It seems that the majority of the time, when I try
to install packages with yum, it fails to resolve dependency errors. I have lots of
repos in which yum can find things:

-rwxr-xr-x. 1 root root  808 Jan 25  2009 atrpms-bleeding.repo
-rwxr-xr-x. 1 root root  748 Jan 25  2009 atrpms.repo
-rwxr-xr-x. 1 root root  799 Jan 25  2009 atrpms-testing.repo
-rw-r--r--. 1 root root  957 Oct 12  2010 epel.repo
-rw-r--r--. 1 root root 1056 Oct 12  2010 epel-testing.repo
-rw-r--r--. 1 root root  248 Aug 12 01:32 k12linux.repo
-rw-r--r--. 1 root root  172 Jun 21 17:13 ltsp.repo
-rw-r--r--. 1 root root   67 Sep  4 15:43 redhat.repo
-rw-r--r--. 1 root root  529 Apr 27 12:58 rhel-source.repo
-rw-r--r--. 1 root root 1002 May 14 11:46 rpmfusion-free-updates.repo
-rw-r--r--. 1 root root 1062 May 14 11:46 rpmfusion-free-updates-testing.repo
-rw-r--r--. 1 root root 1047 May 14 11:49 rpmfusion-nonfree-updates.repo
-rw-r--r--. 1 root root 1107 May 14 11:49 rpmfusion-nonfree-updates-testing.repo

but that doesn't seem to make a difference.

One other point. As of RHEL6.1, numerous programs that always used to be present
in Fedora are now gone. These include

Mozilla seamonkey
VNC
gFTP
uudeview
gkrell
keychain

others look very challenging to install, due to dependencies:

nedit
tgif
... and many others I have tried so far.

I feel like I'm back in the early 2000's, in terms of the frustration with what
should be a polished, commercial Linux.

Any bright ideas?






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]