[K12OSN] SOLVED: Unable to print to thin client attached printer

Jeff Siddall news at siddall.name
Fri Feb 10 03:25:51 UTC 2012

On 01/07/2012 10:21 AM, dmarkovich at drmcs.com wrote:
> Hello,
> I have installed K12Linux on Centos 6.2 per K12Linux Server Install Guide.
> Using EL6-based i686 chroot.
> Have not been able to print to a client attached printer with cups.
> I can print to a direct jet printer attached to the switch on the 1st
> nic card ( non client network-168.192.1. )
> Thin clients are on the second nic (172.31.100. )

Yup.  Confirmed.  Printing busted in SL6.1 client also.  The problem 
seemed to be with the jetpipe app.  When I try to manually run it on the 
client I get:

-bash-4.1# /usr/bin/python /usr/sbin/jetpipe -b 9600 -y 8 -p none -x 
/dev/usblp0 9100
Traceback (most recent call last):
   File "/usr/sbin/jetpipe", line 45, in <module>
     import daemon
ImportError: No module named daemon

However, installing python-daemon in the chroot (part of the epel repo) 
seems to have solved it.  Looks like the ltsp-client package has a 
missing dependency.

Warren, if you are still monitoring this list can you update the 
dependencies on the ltsp-client package?



More information about the K12OSN mailing list