[K12OSN] ltsp 5 usb attached printer problem

Jeff Siddall news at siddall.name
Sat Feb 25 16:51:30 UTC 2012

On 02/24/2012 06:56 PM, Barry R Cisna wrote:
> Hello All,
> On a fresh install of CentOS 6 32-bit with SL6.
> I have three people that HAVE to have their own usb attached printers.
> Each TC has an static ip in dhcpd.conf. When putting in the same
> lts.conf configuration for each TC, from a working ltsp4.2,,other than
> changing the usb path to /dev/usblp0.
> None of the three can i get to work?
> When dropping to a shell on each TC I do see /dev/usb/usblp0.
> But,,As the TC boots I never see anything in regards to the actual
> printer attached for hardware in the scrolling text.
> I have tried many variants of the ltsp4.2 and the documented ltsp 5 usb
> printer installation in the lts.conf file.
> Could someone that has an working usb printer post their lts.conf file
> please?


See my post from a couple of weeks back:

Yup.  Confirmed.  Printing busted in SL6.1 client also.  The problem 
seemed to be with the jetpipe app.  When I try to manually run it on the 
client I get:

-bash-4.1# /usr/bin/python /usr/sbin/jetpipe -b 9600 -y 8 -p none -x 
/dev/usblp0 9100
Traceback (most recent call last):
   File "/usr/sbin/jetpipe", line 45, in <module>
     import daemon
ImportError: No module named daemon

However, installing python-daemon in the chroot (part of the epel repo) 
seems to have solved it.  Looks like the ltsp-client package has a 
missing dependency.


More information about the K12OSN mailing list