[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] k12linux SL6 Install Observations



Hi all,
First a big thank you to the community and Warren for the work done
here. I'm updating a Centos5 install (K12LTSP) to SL6. The following are
"observations" (I put it in quotes since I may have overlooked things or
just plain got them wrong). 

1. Works out of the box when one faithfully follows the documentation.
Kudos.
2. SL6 has the same video issues with a MSI Wind nettop that I'm using
as a test client that I had way back when, iirc, I was in a F12 client
on F12 server. Not a big issue but points out the likelihood that users
will have to do multi chroot installs.
3. Speaking of which, big nuance in multiple chroots (unless I
overlooked something) is that the client only respects the lts.conf in
the original */i386 folder, not the lts.conf in individual chroot
folders, say, */f11_i386. This one took me awhile to chase down. 

If one needs for whatever reason (I'm not here to judge ;-) )to generate
custom lts.confs based on specific chroots, the script is in here: 
    /opt/ltsp/youri386path/usr/sbin/ltsp-client-launch 

For the intrepid, the relevant section is:
TFTPPATH="/ltsp/$ARCH/lts.conf". Amend as necessary. 


4. Another one that killed a few hours. Again, unless I'm getting
something wrong and I'll admit my iptables proficiency is nil: In
previous versions of K12LTSP, one would use 

-A INPUT -i eth? -j ACCEPT 
(where eth? is the interface facing the clients, eg. eth0)
for me, this worked with a earlier k12linux install F13 server on F12
clients that I'm still using at home where I'm using bridged networking
ie ltspbr0 on eth0 and an old K12LTSP EL5 set up with the old style
eth0 / eth1 setup

On my new install, I need to use
-A INPUT -i ltspbr0 -j ACCEPT 
(note that ltspbr0 replaces eth?)

I had tried copying over working iptable configs from both my Centos5
and F13 servers and even generated one with the Firewall utility to no
avail. 

Thanks,
William





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]