[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] no filename or root path error for kvm guest



Hello,
my environment is particular, so some network  errors I get could be
related to it, so I'm going to describe

host1: CentOS 6.2 x86_64 + updates
bridge on vlan bonding (ifcfg-bond0, ifcfg-bond0.65, ifcfg-brvlan65)

On it I have a guest named ltsp with a CentOS 6.2 x86_64 + updates os
and two network adapters, configured as from
https://fedorahosted.org/k12linux/wiki/InstallGuide

eth0 of ltsp is virtual network default lan (192.168.122.x)
eth1 of ltsp is on the bridge (host device bond0.65 (bridge 'brvlan65')

Target network adapter on ltsp server for ltsp services (pxe,dhcp,
nfs, ecc) is eth1, so the bridge vlan

Some test for:
1) virtual machine on VMware infra (vSphere 4.1) with e1000 virtual
adapter on this vlan 65 configured to boot via pxe
It gets all the files via tftp and boots the kernel, but arrives at kernel panic
with rdshell I see before the debug shell

dracut Warning: No dhcp root-path received for '' trying other
interfaces if available
dracut Warning: No root device "dhcp" found

Dropping to debug shell


2) kvm virtual machine on another CentOS 6.2 x86_64 + updates host
with its virtual adapter configured as virtio on this vlan 65
(same bridging architecture as the first host)

It boots and gets ip from dhcp, but then it exits with error because it says
No filename or root path specified
No more network devices

I read other threads referring dnsmasq  but in my case it is the ltsp
server that uses  its ltsp-dhcpd service, so I think it doesn't
apply...

I also read about gpxe versions problems
rpm verison of host and guests are: gpxe-roms-qemu-0.9.7-6.9.el6.noarch
I tried binary rom from bugzilla 594682 to boot my guest but with it,
the pxe of guest doesn't work at all....
I tried also from rom-o-matic to build and download all possible
binary roms for virtio up (0.9.9 and up to git)
All gives the same error as former one and the git one doesn't work,
as the bugzilla one...
I also tried all the other possible network adapter types for the kvm
guest with the same error (e1000, rtl8139, pcnet, ne2k2_pci)....

So I tried manually:
- boot from pxe and type Ctrl+B
- dhcp net0 --> and I get ip
- config
and set these:
      next-server 10.4.4.54  (my ltsp ip address)
      filename /ltsp/i386/pxelinux.0
      root-path 10.4.4.54:/opt/ltsp/i386
Ctrl+X to exit config
- autoboot

And voila'.... the guest starts perfectly in a graphical desktop!
SO I presume it is my config with problems... How to debug and fix my
config on ltsp ?

Question:
Suppose I want to have a mix of thin clients (as this one) and also
standard Linux stations I want to connect to the ltsp server in
similar way.
How should I set up these latest ones? The ltsp starts its Xorg this way
/usr/bin/Xorg :0 -nr -verbose -audit 4 -auth
/var/run/gdm/auth-for-gdm-nsOyvb/database -nolisten tcp vt1

so it is not using xdmcp....
Any hint?

Thanks in advance for your work.

Gianluca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]