[K12OSN] Anyone get Fedora 16 chroot working?

Jeff Siddall news at siddall.name
Wed Oct 3 02:45:14 UTC 2012

I mucked with the /etc/sysconfig/ltspdist to allow F16 then ran 

The good news is the client appeared to build (got success message at 
the end despite some warnings along the way).

The bad news is that the chroot wasn't really functional.

I started by moving it to a suitable place (/opt/ltsp/i386-f16) and ran 
ltsp-update-kernels but no joy.

First it complained about no pxelinux.0.  Sure enough, nothing in the 
tftp directory.  So I just copied the pxelinux* files from the EL6 
chroot i386 directory and that got things further.

The next problem was a kernel panic due to dracut not knowing what to do 
with "root=dhcp".  Hmmmmm... so I ran chroot in /opt/ltsp/i386-f16 and 
then ran ltsp-rewrap-latest-kernel and got an error about missing dhclient.

So I checked and sure enough no dhclient.  That can't be right.  So I 
installed it and re-ran ltsp-rewrap-latest-kernel.  This time I only got 
some errors about "grep: /proc/modules: No such file or directory". 
Fair enough.

So I re-ran ltsp-update-kernels but still no joy.  This time the boot 
process hung for about 20 seconds and returned with "dracut Warning: 
unable to process initqueue" and then dropped into a shell.

I am doing all this to try to get a working eGalax touchscreen which is 
borked in EL6 but worked fine in Fedora as far back as version 14. 
Sigh.  Anyone have any tips for getting a F16 client (or an eGalax 
touchscreen) working on a EL6 server?



More information about the K12OSN mailing list