[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Trouble with PXE Boot; Fedora 17



Adrin,

K12Linux installation instruction
(https://fedorahosted.org/k12linux/wiki/InstallGuide) says:
"Fedora 15+ WILL NOT WORK". I don't know is this Fedora status changed.

I recomend you CentOS 6.3.

Best regards,
Radek
---
> Hello; I'm new to LTSP and generally a novice to Linux.  I installed
> all LTSP-related packages using Fedora 17's Add/Remove Software (GUI).
> I then followed the instructions on the k12linux site.
> 
> 
> 1) Everything on the server side installed "properly", except for step
> 8: there is no ltsp-server-tweaks on my system. I don't know if this
> is relevant to my problem or not. Anyway, I'd appreciate a hint as to
> where I can download and install  ltsp-server-tweaks
> 
> 
> 2) The client setup step failed because I'm running F17. If there are
> instructions I can follow to successfully complete the latter, I'd
> really appreciate the link. (I'm using the workstation only as a
> server, and I have a fairly powerful diskless thin/zero client, which
> I just purchased for remote computing purposes)
> 
> 
> 3) My system is 64-bit (and so is F17). Is there any reason ltsp
> defaults to 32-bit even though there are x86-64 ltsp directories/files
> as well?  Is there a way to just stick with x86-64?
> 
> 
> 4) The main reason for this thread, which I assume/hope is independent
> of the above three "issues", is the fact that trying to PXE boot via
> the Virtual Machine fails (so does PXE booting from the diskless
> client, of course) with the message "No DEFAULT or UI configuration
> directives found!".  The following are the last few lines before the
> error message, and googling the latter didn't turn up anything useful
> for me:
> 
> 
> (text in brackets are my comments)
> 
> 
> [IP address is assigned]
> BOOTIF= [hexadecimal numbers]
> SYSUUID= [hexadecimal numbers]
> TFTP prefix: /ltsp/i386/
> Trying to load:  pxelinux.cfg/default   ok
> No DEFAULT or UI configuration directives found!
> boot:  [blank space]
> 
> 
> 
> 
> 
> The following is the content of the "default" file
> 
> 
> prompt 0
>  label linux
>  kernel vmlinuz.ltsp
>  append rw initrd=initrd.ltsp selinux=0 root=dhcp quiet rhgb
> 
> 
> 
> 
> 
> The following are the relevant ifcfg files
> 
> 
> [root vortex network-scripts]# more ifcfg-p1p1
> UUID="36f1f167-eeef-45ad-9a03-9a1567b985a7"
> NM_CONTROLLED="no"
> BOOTPROTO=none
> DEVICE="p1p1"
> ONBOOT="yes"
> TYPE=Ethernet
> DEFROUTE="yes"
> IPV4_FAILURE_FATAL=no
> IPV6INIT=no
> NAME="System p1p1"
> HWADDR=10:BF:48:07:6F:6C
> BRIDGE=ltspbr0
> USERCTL=yes
> 
> 
> 
> [root vortex network-scripts]# more ifcfg-ltspbr0
> # Sample Configuration for Initscript Driven Bridge
> # Put this into /etc/sysconfig/network-scripts/ifcfg-ltspbr0
> #
> # Warning: Deleting ifcfg-ltspbr0 alone to disable ltspbr0 will cause
> you
> # problems, because it will come back the next time you upgrade the 
> # ltsp-server package. 
> #
> # Comment out these two lines to disable ltspbr0.
> ONBOOT=yes
> IPADDR=172.31.100.254
> 
> DEVICE=ltspbr0
> TYPE=Bridge
> BOOTPROTO=static
> STP=off
> DELAY=0.1
> USERCTL=no
> IPV6INIT=no
> PEERDNS=yes
> NETMASK=255.255.255.0
> ARP=yes
> 
> 
> Thank you very much, in advance, for helping me get started
> 
> 
> adrin
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]