[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] No reaction following lts.conf changes



Barry,

Many thanks for your help. Unfortunately nothing works.

Let me set in order my lts.conf manipulations.
I can add, that I tested my lts.conf LTSP 5.1. All work fine excluding
Fedora 10 image, but let's forget about it now. It is the reason that I
copy parts of lts.conf from LTSP 5.1 to lts.conf LTSP 5.9.

1)
I test LTSP 5.9 now (thin client i386 epel6).
Thin client boots and I can log in. But what is strange - every time
after booting thin client I write user login name and push Enter to move
to password line, login screen reloads. Sometime I must repeat twice or
three times procedure when I can write password and log in.

The resolution of the screen is 1680x1050 only. But thin client works
fine (I solved my troubles with two NICs and network).

After log off I try to switch to Windows 7 screen (xfreerdp). I can see
black screen with blanking pointer. I checked my lts.conf. All line with
xfreerdp command uses " ".
Next I assured myself
regarding /opt/ltsp/i386/usr/share/ltsp/screen.d/xfreerdp. 
export HOME=${HOME:-/root} line exists.
I remember that this change
in /opt/ltsp/i386/usr/share/ltsp/screen.d/xfreerdp file was necessary in
LTSP 5.1, but 5.9 corrected this bug.

I try to come back to SCREEN_01 with LDM. I can see black screen with
the following information:

"
Traceback (most recent call last): File "/usr/sbin/firstboot", line 168,
in <module> config.front.end.start()

File "/usr/lib/python2.6/site-packages/firstboot/xfrontend.py", line 64,
in start with open ("/etc/sysconfig/i18n", "r") as f: 10 Error: [Error
2] No such file or directory.
"

2)
Still LTSP 5.9. I added (from my backup) thin client image from LTSP 5.1
to /opt/ltsp and /var/lib/tftpboot directory and configured ltsp-dhcpd.
Thin client boots, but I can see last text screen before login screen.

3)
The behaviour of LTSP described in 1) point is the same like with LTSP
5.1 and Fedora 10 image. It means that I can see on SCREEN_01 LDM, but I
can't reach Windows screen (rdesktop) on next screen described in
lts.con file.
Somebody could ask wile Fedora 10 image? Fedora 10 image cooperates with
very old machine (K6 III 400) with GeForce 2 MX 200.

So I still looking for the solution.

Best regards,
Radek

---
> Radek,
> 
> What may be your problem is if HOME is unset xfreerdp segfaults.
> 
> Open /opt/ltsp/i386/usr/share/ltsp/screen.d/xfreerdp
> 
> At almost the top of this file You will see a line ..
> . /usr/share/ltsp/screen-x-common
> Below this line you should have ,,,
> export HOME=${HOME:-/root}
> 
> If the above line is not there,, add it,,SAVE
> 
> reboot your TC,,
> Your rdesktop will work on the TC now.
> 
> Take Care,
> Barry
> 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]