[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] client booting linux stalls



You'll need to rollback to an older kernel version for the TC or compile your own. RedHat dropped support for CPU styles from 15 years back and many SoC devices that are not ARM are still i586 command sets.

On Jun 7, 2013 5:22 AM, "Johan Vermeulen" <jvermeulen cawdekempen be> wrote:
hallo Joshua,

thanks for getting back to me.

* I just ran

#yum clean all && yum update

and that worked;

ltsp-server-5.4.5-21.el6.x86_64
ltspfs-1.1-7.el6.x86_64
ltsp-release-5-9.el6.noarch


* I then did :

#mv /opt/ltsp /opt/ltsp.old

#ltsp-build-client

# ltsp-update-image
Your system seems to be using NFS to serve LTSP chroots.
If you're absolutely certain you want to switch to NBD, run:
    /usr/sbin/ltsp-update-image --config-nbd

# ltsp-update-kernels
Updating /var/lib/tftpboot directories for chroot: i386
Skipping invalid chroot: mock


* I then booted the hp thinclient: same green screen.
I will try to send you a screenshot of that.
I checked the hardware of this hp thinclient:
it has a Via Eden processor 1000Mhz,

Googling the " unsupported processor centaurhauls" message I find this :

nybody know the reason RedHat decided not to support the
>>> VIA Eden Processor?

If you take a look on google for "CentaurHauls i686" you will see that
> this CPU/chipset SAYS it fully supports i686 but it really does not. > All of EL6 is i686 and not i586 (which CentaurHauls really fully supports).

So this suggests that Centos has an issue with this thinclient
There's also this site :

https://access.redhat.com/site/solutions/388693

that I don't have full access to.

But then I don't understand why so far I had no issues with k12Linux on Centos?????

* I then put together a new thinclient, with motherbord Gibabyte GA-c847n, intel Celeron processor.

When booting this, i also see some EM, but K12Linux boots fine, and...

There's no green screen. It just works

So this fully suggests that the issue is the HP t545 thinclient.

This is a showstopper for me, because this is our mainline thinclient.

Thanks for any advise on this issue.

Greetings, J.


Op 06-06-13 00:36, Joshua Trimm schreef:
Johan, Try first cleaning your cache by doing a 'yum clean all' then 'yum update' and let me know if that works for you.

The green glare issue i'm unfamiliar with, could you take a screenshot and post a link to it directly to my email?
Thanks,

On 6/5/13 2:55 AM, Johan Vermeulen wrote:
hello Jushua,

thanks for letting me know.

*the routing problem was solved by editing the iptables manualy.

* I did put "em2" in /etc/ltsp/ltsp-server.conf before running the scripts.

* my original install was with epel, yesterday evening I updated with the other repo:

[root centoshofkwartier ~]# yum repolist
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: distrib-coffee.ipsl.jussieu.fr
 * extras: mirror.ovh.net
 * ltsp: ltsprepo.s3.amazonaws.com
 * updates: distrib-coffee.ipsl.jussieu.fr
repo id                        repo name                                  status
base                           CentOS-6 - Base                            6381
extras                         CentOS-6 - Extras                            12
ltsp                           LTSP - x86_64                                60


but something went wrong with the update,because my version is still:

[root centoshofkwartier ~]# rpm -qa | grep ltsp
ltsp-server-5.4.5-20.el6.x86_64
ltspfs-1.1-7.el6.x86_64
ltsp-release-5-9.el6.noarch


* I then rebuilded with ltsp-build-client

but the problem with the green glare stays.
Everything 's on the screen, but there's this filter over it......

Maybe this can be solved by editing lts.conf.....

greetings, J




Op 04-06-13 20:46, Joshua Trimm schreef:
Johan, I have 5.4.5-21 being pushed to the repo's today which should fix the scripts to accept an interface regardless of its name.

The reason NFS needs to be started manually is due to the RPM not knowing which interface you will be using for the LTSP network. This must be defined in /etc/ltsp/ltsp-server.conf before ltsp-server-tweaks and ltsp-server-initialize are run.
On 6/4/13 5:23 AM, Johan Vermeulen wrote:
Dear All,

this is my experience with the install :

version is ltsp-server-5.4.5-20.el6.x86_64 on Centos6.4.
installed with epel-repo.

After starting nfs manualy like Barry and starting tftp manualy, I am able to boot a thinclient.

But I'm facing these problems :

*ltsp-server-tweaks hangs on " about to overwrite your firewall config" either with iptables on or off.
Probably because of that, laptops and workstations that are on the lan cannot reach the internet. This is my main concern.
Setting up nat manualy did not help.

this is /etc/sysconfig/iptables :

# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*nat
:PREROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
-A POSTROUTING -o eth+ -j MASQUERADE
-A POSTROUTING -o em2 -j MASQUERADE
COMMIT
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i eth+ -j ACCEPT
-A INPUT -i em2 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
-A FORWARD -p icmp -j ACCEPT
-A FORWARD -i lo -j ACCEPT
-A FORWARD -i eth+ -j ACCEPT
-A FORWARD -i em2 -j ACCEPT
-A FORWARD -o eth+ -j ACCEPT
-A FORWARD -o em2 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT

*ltsp-server-initialize gives me a lot of EM. But the thinclient boots, so maybe that's not a problem.

*when booting the thinclient, I get an EM : unsupported device : processor centaurhauls
  The thinclient is an HP hstnc-004 that I used on 3 different thinclient systems in the past 3 years.
  It would be a real problem if it doesn't work with this image.

*when booted, I am able to log in, and adapt language and other settings in lts.conf. But I can't get rid of the green glare that is over the
screen.
Could be the Acer monitor, but it's fine when attached to other devices.

Any input on these issues would be greatly appreciated.

greetings, J.


Op 03-06-13 20:20, Barry Cisna schreef:
Hello All,

Replying to my previous post.
For completeness.

The fix for the 'stuck' Booting Linux line was I did not have nfs
service started at boot on the server and had to manually enter
the /opt/ltsp dir in nfs/exports.
After this clients will boot fine.

Take Care,
Barry


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]