[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Help? Programs not Running?



Yes.
I read the docs and also assumed that ltspbr0 was no longer needed.
I went ahead and properly deleted the bridge with "brctl delbr ltspbr0".
"Service network restart" did not do the trick; clients still would not connect.
The next logical thing for me was to reboot the server. Was I surprised when I got a Kernel Panic as soon as SL started to load.
Used some live CDs to recreate the bridge to at least have a booting system but no such luck.
Time was running out and I could not spend to much of it to continue troubleshooting it.
Rebuilding the server was a faster option for me.

Sergio






On Wed, May 8, 2013 at 10:37 PM, Burke Almquist <burke thealmquists net> wrote:
>From the looks of the new instructions here. http://wiki.ltsp.org/wiki/Category:Fedora if you read the /usr/share/doc/ltsp-server-5.4.5/README.rpminstall file, you will see they aren't using the bridge anymore. At least that was my understanding when I read it. It's not totally clear to me. The thin client network and dhcp appears to be set up to use the 192.168.67.0 subnet.

Looks like the jump to the newer versions of LTSP that were setup to use EL 6.4 made a number of changes. If you update you are going to have to check your configuration. It's not just a simple update.


On May 8, 2013, at 5:56 AM, Sergio Chaves wrote:

> Well, no joy on my end.
> I tried the tips given here and could not make it work. System still claimed ltspbr0 as garbage.
> Not willing to give up, I decided to remove the bridge with "ifdown eth1; brctl delbr ltspbr0" and reboot.
> Not the brightest idea; now I get an instant kernel panic at boot.
>
> Time for reload.
> These servers are for kids classes at church and need to be ready for the weekend.
> Thanks everybody for the help and the tips.
>
> Sergio
>
>
>
> On Mon, May 6, 2013 at 5:32 PM, Sergio Chaves <sergio chaves gmail com> wrote:
> Joshua,
>
> Thanks for the follow up.
> I did not have a chance to get to the "bad" server yet - I do not like Mondays :-)
> It maybe later tonight or tomorrow afternoon before I get to it.
>
>
> On Mon, May 6, 2013 at 4:37 PM, Joshua Trimm <enslaver enslaver com> wrote:
> Any luck with getting things working? I am the K12Linux developer for EL6 LTSP and I can assist if anyone is still having issues. I also am available by skype username: joshtrimm until about 6pm CST
>
>
> On 5/5/13 8:08 PM, Sergio Chaves wrote:
>> Jim,
>>
>> Thanks for the tips.
>> Got one server ready to go. I will check on the failing one tomorrow afternoon and let you know of the results.
>>
>>
>> On Sun, May 5, 2013 at 3:39 PM, Jim Kinney <jim kinney gmail com> wrote:
>> double check that the bridge device ltspbr0 actually exists (check lsmod - check ifconfig and /etc/sysconfig/network_scripts/ifcfg-* )
>> Double check that ip_forwarding is still OK
>>
>> watch the dhcpd log with tail -f  while things are trying to connect and see if the server "sees" anything.
>>
>> double check the firewall allows incoming dhcp requests.
>>
>> HOWEVER: I'm assuming the clients are regular LTSP clients so they already get dhcp during their PXE boot phase - thus dhcp IS working.
>>
>> run back through the /var/log/yum.log and see what was updated.
>>
>>
>> On Sun, May 5, 2013 at 9:22 AM, Sergio Chaves <sergio chaves gmail com> wrote:
>> Not to Hijack the thread but I updated 02 of my servers - Scientific Linux 6 - yesterday afternoon and after that, clients no longer can authenticate and get a login screen. Also updated ssh-keys, verified the dhcp server, etc.
>> The only noticeable error message I see is that when the servers are coming up, the system says that either ltspbr0 is duplicated by dev or, it is garbage.
>> Eth1 however, initializes fine. Just no DHCP offers. I have uninstalled the ltsp-server, re-installed it and rebuilt the client with ltsp-build-client.
>> Something must have changed in a config file that I am missing it big time.
>> Google returned many unrelated things
>> If I cannot figure it out soon, it will be a long night tonight.
>>
>> Sergio
>>
>>
>>
>> On Thu, May 2, 2013 at 5:30 PM, David C. Moody <davidm trustholiday com> wrote:
>> Hello everyone,
>>
>> I need some help.  I was doing my standard update today to keep the system up to date and it blew up in my face.
>>
>> Now after finally working all day and getting the users able to log back in.  They can log in, and run any apps that run via ltsp-local-apps, however any apps that run on the base system cause the user to get kicked out back to the login screen.
>>
>> Pertinent system information:
>>
>> [root shopltsp ~]# rpm -qa|grep ltsp
>> ltsp-release-5-9.el6.noarch
>> ltsp-server-5.4.5-20.el6.i686
>> ltspfs-1.1-7.el6.i686
>>
>> [root shopltsp ~]# cat /etc/*release*
>> CentOS release 6.4 (Final)
>> LSB_VERSION=base-4.0-ia32:base-4.0-noarch:core-4.0-ia32:core-4.0-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-ia32:printing-4.0-noarch
>> cat: /etc/lsb-release.d: Is a directory
>> CentOS release 6.4 (Final)
>> CentOS release 6.4 (Final)
>> cpe:/o:centos:linux:6:GA
>>
>>
>> This is what I'm seeing in messages log:
>>
>> [root shopltsp log]# tail messages
>> May  2 17:36:17 shopltsp gnome-keyring-daemon[3579]: dbus failure unregistering from session: Connection is closed
>> May  2 17:36:18 shopltsp xinetd[1474]: START: ldminfod pid=3673 from=::ffff:192.168.10.15
>> May  2 17:36:18 shopltsp xinetd[1474]: EXIT: ldminfod status=0 pid=3673 duration=0(sec)
>> May  2 17:36:41 shopltsp spice-vdagent[3861]: Missing virtio device '/dev/virtio-ports/com.redhat.spice.0': No such file or directory
>> May  2 17:37:00 shopltsp gnome-keyring-daemon[3863]: dbus failure unregistering from session: Connection is closed
>> May  2 17:37:00 shopltsp gnome-keyring-daemon[3863]: dbus failure unregistering from session: Connection is closed
>> May  2 17:37:01 shopltsp xinetd[1474]: START: ldminfod pid=3963 from=::ffff:192.168.10.15
>> May  2 17:37:01 shopltsp xinetd[1474]: EXIT: ldminfod status=0 pid=3963 duration=0(sec)
>> May  2 17:37:57 shopltsp spice-vdagent[4151]: Missing virtio device '/dev/virtio-ports/com.redhat.spice.0': No such file or directory
>> May  2 17:40:14 shopltsp avahi-daemon[1195]: Invalid query packet.
>>
>>
>> I've done some googling, but I've been unable to turn up anything that corrects the problem as of yet.
>>
>> Thanks for any help!
>> -David
>>
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>>
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>>
>>
>>
>> --
>> --
>> James P. Kinney III
>>
>> Every time you stop a school, you will have to build a jail. What you gain at one end you lose at the other. It's like feeding a dog on his own tail. It won't fatten the dog.
>> - Speech 11/23/1900 Mark Twain
>>
>> http://electjimkinney.org
>> http://heretothereideas.blogspot.com/
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>>
>>
>>
>> _______________________________________________
>> K12OSN mailing list
>>
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>>
>> For more info see
>> <http://www.k12os.org>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]