[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] howto update



Hello Joshua, hello All,

I'm trying the update described below on a Centos6.4 machine.

After swapping repo, I now have :

[root centos-server ~]# yum repolist
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirrors.atosworldline.com
 * extras: mirrors.atosworldline.com
 * ltsp: ltsprepo.s3.amazonaws.com
 * updates: mirror.ate.info
repo id                        repo name                                  status
base                           CentOS-6 - Base                            6381
extras                         CentOS-6 - Extras                            12
ltsp                           LTSP - x86_64                                61
updates                        CentOS-6 - Updates                          694
repolist: 7148

When I now run # yum update
I'm getting trouble with package libjpeg-turbo

output:

       Protected multilib versions: libjpeg-turbo-1.2.1-1.el6.i686 != libjpeg-turbo-1.2.90-20130204.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It seems to me both Centos Base repo and ltsp-repo want to give me this package:

[root centos-server ~]# yum whatprovides libjpeg-turbo
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirrors.atosworldline.com
 * extras: mirrors.atosworldline.com
 * ltsp: ltsprepo.s3.amazonaws.com
 * updates: mirror.ate.info
libjpeg-turbo-1.2.1-1.el6.i686 : A MMX/SSE2 accelerated library for manipulating
                               : JPEG image files
Repo        : base
Matched from:



libjpeg-turbo-1.2.1-1.el6.x86_64 : A MMX/SSE2 accelerated library for
                                 : manipulating JPEG image files
Repo        : base
Matched from:



libjpeg-turbo-1.2.90-20130204.x86_64 : A SIMD-accelerated JPEG codec that
     ...: provides both the libjpeg and TurboJPEG APIs
Repo        : ltsp
Matched from:



libjpeg-turbo-1.2.1-1.el6.x86_64 : A MMX/SSE2 accelerated library for
                                 : manipulating JPEG image files
Repo        : installed
Matched from:
Other       : Provides-match: libjpeg-turbo

Does anybody else have this problem?

Kind regards, J.



Op 09-04-13 18:39, Joshua Trimm schreef:
Hello Johan, i've written up some very basic instructions to help get started at: https://fedorahosted.org/k12linux/wiki/EL6Status the rpm's are also being pushed to stable in EPEL. I have also started on some documents that will help guide you through the process that should be included in the latest RPM's, the files are called README.rpminstall and QuickInstall-el6. The important thing to note about this upgrade is that k12linux is become more tightly integrated with ltsp therefore the repo's are different for the newer versions. 5.2.17 will possibly remain at http://mplug.org/~k12linux/rpm/el6/ while the newer repo is located at http://mirror.ancl.hawaii.edu/~k12linux/rpm/. So here is some preliminary (untested) instructions for upgrading.

1. rpm -e k12linux-release
2. rpm --import http://mirror.ancl.hawaii.edu/~k12linux/rpm/RPM-GPG-KEY-ltsp
3. rpm -Uvh http://mirror.ancl.hawaii.edu/~k12linux/rpm/ltsp-release-5.noarch.rpm
4. yum clean all
5. yum update

Note: iptables/selinux is the reason for most people's issues, disable those first temporarily to get everything setup.

That should offer to upgrade your ltsp-server, ltspfs, ldm and other packages required. I have this tested on EL6.3 and 6.4 with CentOS, Red Hat and Scientific Linux. If you have any issues feel free to contact me or shout out to all of us in #ltsp on irc freenode.

On 4/9/13 2:33 AM, Johan Vermeulen wrote:
Dear All,

I saw on Facebook that there was an update on 17th of March ( I am not subscribed to the announcement list )

I have k12linux repo enabled on some machines and I'm trying to run yum update, that doesn't seem to work.

How to update this?

My current version :

[root deveder yum.repos.d]# rpm -qa | grep ltsp
ltsp-server-5.2.17-1.el6.i686
ltspfs-0.8-2.el6.i686

Thanks for any advise.

greetings, J.

Opensource Software is the future.

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]