[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] yum update issue with ltspbr0



Well, may be the laziness in me worked to my advantage :-)
I am still to fix my second server and will try this approach!

Thanks for the tip William!


On Thu, May 16, 2013 at 12:52 PM, William Fragakis <william fragakis com> wrote:
I don't know if this will shed any light for those who've been suffering
similar woes.

short version: on ltsp server restart, ltsp-dhcpd failed to start and
ltspbr0 was dead. thin clients couldn't boot. update erased
ifcfg-ltspbr0 but copying ifcfg-ltspbr0, bringing up ltspbr0 and
starting ltsp-dhcpd solved everything.

long version:

We had a server restart this morning. Someone unfortunately punched the
reset button on the ltsp server instead of the dead windows box.

Server came back online but thin clients couldn't get ip address to
begin booting. Panic developed as this was in the middle of a workday.

service ltsp-dhcpd status showed dhcp was dead and restarting it failed
with system log saying something about undeclared subnets, etc.

ifconfig didn't show anything for ltspbr0

Listed the files in /etc/sysconfig/network-scripts that started with
ifcfg-l and got
ifcfg-lo ifcfg-ltspbr0~ and ifcfg-ltspbr0.rpmnew

But no ifcfg-ltspbr0

Copied ifcfg-ltspbr0.rpmnew to ifcfg-ltspbr0 , did an ifup on
ifcfg-ltspbr0 and then ltsp-dhcpd restarted without any problems. thin
clients booted and my heart was no longer pounding.

Moral of the story, an update incorrectly killed existing ltspbr0 config
file.  Hope this helps. I didn't see this mentioned elsewhere so sorry
if it duplicates anything.

Not sure which update killed it or to whom I should submit bug report.
Suggestions appreciated.

thanks,
William




_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]