[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] pcscd dead



Hello All,

reïnstalling hal didn't do the trick.
I tried the chown haldaemon command, that didn't work. I did not succeed in caching log files in /tmp/hal.log
nor do i see other haldaemon related EM.
But I managed to get messagebus running (dbus ) and I now see these hald processes:

bash-4.1# ps auxw | grep hald
68        1703  0.0  0.2  17676  4784 ?        Ssl  02:40   0:00 hald
root      1704  0.0  0.0   3980  1104 ?        S    02:40   0:00 hald-runner
root      1745  0.0  0.0   4052  1140 ?        S    02:40   0:00 hald-addon-input: Listening on /dev/input/event0 /dev/input/event1
68        1750  0.0  0.0   3644   980 ?        S    02:40   0:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root      3105  0.0  0.0   4376   776 ?        S+   03:05   0:00 grep hald

I also see this in /var/log/messages when starting pcscd :

Jul 15 02:38:43 tpoortje pcscd: hotplug_libhal.c:465:HPRegisterForHotplugEvents() error: dbus_bus_get: org.freedesktop.DBus.Error.AccessDenied: An SELinux policy prevents this sender from sending this message to this recipient (rejected message had sender "(unset)" interface "org.freedesktop.DBus" member "Hello" error name "(unset)" destination "org.freedesktop.DBus")

So it could be a Selinux issue.

To solve this it tried the command :

echo 0 > /selinux/enforce

and I modified /etc/selinux/config

Neither helped.

Greetings, J.







----- Oorspronkelijk bericht -----
Van: "William Fragakis" <william fragakis com>
Aan: k12osn redhat com
Verzonden: Maandag 14 juli 2014 19:29:51
Onderwerp: Re: [K12OSN] pcscd dead

Johan,

This may be totally unrelated but since permissions and haldaemon are
being mentioned...

I've run into an issue when cloning running systems via rsync. For some
reason, the permissions for haldaemon cache wouldn't be correct. 

The following cleared up the issue:

chown haldaemon:haldaemon /var/cache/hald

if you suspect this might be the issue, you can run this 

hald --daemon=no 2>&1 | tee /tmp/hal.log

then
cat /tmp/hal.log

to see what the log shows.


Again, may have nothing to do with your problem. 

Regards,
William




On Mon, 2014-07-14 at 12:00 -0400, k12osn-request redhat com wrote:
> Van: "Barry Cisna" <cisna-barry wc235 k12 il us>
> Aan: "K12LTSP Mailing List" <k12osn redhat com>
> Verzonden: Maandag 14 juli 2014 13:55:57
> Onderwerp: Re: [K12OSN] pcscd dead
> 
> Johan,
> 
> >From the looks of your last posted message here it may be simply a
> permissions ,(on the client chroot, of course),thing with the pcsd
> executable? 
> 
> Just do an 'chmod -c -R 777 /'   ,,,to the pcsd directory along with
> the
> actual pcsd executable/shell script.
> 
> Try restarting the pcsd service and see if this same error is thrown.
> 
> Kind of a rough way to do it but worth a try.
> 
> Barry


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]