[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Problems with NFS install...



Thanks all for your comments.  Unfortunately, I still do have it working.
Previously, I was attempting to use a ks.cfg on the floppy.  I tried to load
the ks.cfg from the nfs server, but I get the error that it can't find file
"/tmp/ks.cfg".  Is it supposed to be in a /tmp dir under the nfs share or is
this just something that it tries when it can't connect to the nfs server?

I also tried switching to a basic linux nfs server (rather than connecting
to the netapp directly).  Still with the same results though.

So to recap, I made the modification to syslinux.cfg to be:
default kickstart
prompt 1
timeout 2
label kickstart
  kernel vmlinuz
  append ks=nfs:192.168.1.90:/mnt/kickstart/ks.cfg initrd=initrd.img network

The setup starts, prompts me for which ethernet card (eth0, eth1, eth2), I
select eth0 then it tells me is can't find "/tmp/ks.cfg".  By this time,
it's already leased an IP and bound it to eth0 (I can ping it).  Any more
ideas?  Should I switch to ftp?

Thanks!

-Stephen Bolinger

When I boot to the

> On Tue, 28 Nov 2000, Stephen Bolinger wrote:
>
> > The install begins to go into a manual install and asks if I
> want an NFS,
> > FTP or HTTP install.
>
> There's something wrong here with where ever it is you have put
> your ks.cfg.
> The installer can't find it for whatever reason (otherwise it wouldn't be
> asking you what type of install you need :-).
>
> It's also been my experience that if you try to use the ks option and the
> kickstart can't find a ks.cfg anywhere, it'll pretend to drop back to a
> manual install but it'll fail (exactly like you're describing) when you
> try to continue by manually feeding in the information.
>
> Check your syslinux.cfg for the image you're using to boot and make sure
> that you have something that looks like:
>
> label kickit
>   kernel vmlinuz
>   append ks=nfs:192.168.1.90:/kickstart/ks.cfg initrd=initrd.img network
>
> Note that we're assuming your ks.cfg is in the NFS dir above.  And we're
> also assuming that you're using a NetApp filer and that /kickstart will be
> aliased automagically to /vol/vol0/kickstart. :-)
>
> Take it easy,
>
> --
> Kelley Spoon                                        Main: 210-892-4000
> Rackspace Managed Hosting                            Fax: 210-892-4329
> 112 East Pecan, Suite 600                  Email: kspoon rackspace com
> San Antonio, TX 78205                       <http://www.rackspace.com>
>
>
>
> _______________________________________________
> Kickstart-list mailing list
> Kickstart-list redhat com
> https://listman.redhat.com/mailman/listinfo/kickstart-list
>





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]